interrupted program, cyclone unresponsive

By Jessica B. : May 24, 2023 at 09:50 AM (09:50 hours)
Staff: Johnny N. : 4 comments

I'm using cycloneControlConsole.exe in an automated fixture to program a stored image in our Cyclone LC. If the programmer loses the connection to the processor it gets stuck. Trying to call cycloneControlConsole.exe again fails. The screen on the cyclone shows it's in the middle of programming. I tried waiting and it never error out. I have to hit the cancel button before it becomes responsive to commands again. This manual intervention requires the operator to open the fixture. Is there a way to reset the unit from the console? Is there an update to the cyclone which will stop trying to programming if it loses connection?

Hi Jessica,

Some of our algorithms have a timeout which should cause the Cyclone to error out and not get stuck. Can you tell me which Cyclone LC and .arp file you are using?


we use the following arp files with our two fixtures:
- ST_STM32L071CB_1x32x1536_eeprom.arp
- ST_STM32L071CB_1x32x32k.arp
- Nordic_nRF52840-QIAA_1x32x256k.arp

I just tried programming the STM32 at my desk and it did timeout when the connection was interrupted, or never connected to begin with. Something may be different between the test I just did and our deployed fixture. I will have a remote support session with the factory tonight and hopefully I will have more information tomorrow.


Please also note the following command will reset the Cyclone LCs

cyclonecontrolconsole.exe -cyclone=USB1 -resetcyclone

Of course, this assumes the connection from PC <-> Cyclone is active and Cyclone is still responding to host commands.