PEmicro logo
Cart New Account Login

Logo image
HomeAbout usProductsSupportForumsBlogCustomer Service

search inside this forum
search inside all forums
Cannot program STM 32L4S5 device on JTAG chain
Niall M. Jul 26, 2021 at 12:38 PM (12:38 hours)
Staff: Johnny N.

  • I am trying to program a device on a JTAG chain TAP=2 IRPre=8 (CortexM4).
    I can program and debug this device using these settings without a problem using either the J-Link or J-Flash devices but when I try with the cyclone LC all I get is error 7 cannot enter debug mode.
    I have checked cable pinout - All OK.
    I have tried reducing shift frequency (2Mhz)
    and I have tried using a specified delay all to no avail.

    I am using the 20 pin port 'H' which I believe is the correct port

    The device is being driven into reset and then the programming fails.

    As we use the PEMicro device for production programming this is causing major headaches.


    Help please

    Niall




    Comments

  • Niall,

    Thank you for reaching out and sorry about the trouble.

    The first step I would take is to verify communication and programming with a single STM32L4S5 device. Can you run our progacmp.exe software in the InteractiveProgrammer folder? Then try to connect to the first STM32L4S5 and program the single board without using any JTAG chain settings.

    If this test fails, then we might have an issue with our run control or algorithm and not specifically with the JTAG chaining.

    -Johnny
    PEMICRO

    • Niall,

      Any updates?

      -Johnny

Add comment


   Want to comment? Please login or create a new PEmicro account.







© 2021 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement