PEmicro logo
Cart New Account Login

Logo image
HomeAbout usProductsSupportForumsBlogCustomer Service

search inside this forum
search inside all forums
Why Cyclone LC program with HCS12 can't work but Cyclone Pro work fine?
Wayne L. May 2, 2021 at 11:08 PM (23:08 hours)
Staff: Takao Y.

  • Dear
    I use same phy file same flow to program S12XEG128, when the code programed with legacy Cyclone "Pro" chip work fine, but use new Cyclone the chip can't work anything I miss to do before use Cyclone LC ?

    1. I had dump code to check no any different.
    2. All of algorithms file select correct.




    Comments

  • Greetings,

    1) So you tried using upload module between the two cyclones and they match?

    Did you make sure to check all memory locations, including EEEPROM and partitioning of memory?


    Takao

  • Hi Takao
    1) So you tried using upload module between the two cyclones and they match?
    Yes.

    Did you make sure to check all memory locations, including EEEPROM and partitioning of memory?
    Yes, I check the P-Flash and D-Flash all of the same.

  • Greetings,

    If the memory is exactly the same, then I would also expect same behavior after power cycling the board. Are you power cycling the board after programming then checking the behavior? Or are you only looking at behavior just as programming finished?

    The only other thing the cyclones are writing are debug registers that would reset after a power cycle so the behavior should match.


    Takao

Add comment


   Want to comment? Please login or create a new PEmicro account.







© 2021 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement