PEmicro logo
Cart New Account Login

Logo image
HomeAbout usProductsSupportForumsBlogCustomer Service

search inside this forum
search inside all forums
FRDM-KL46Z - trying to update boot loader and firmware with errors
Mark G. Feb 6, 2021 at 06:18 PM (18:18 hours)
Staff: Zahar R.

  • Hi,

    I've been trying to update my KL46Z board with your most recent boot loader and firmware. I'm using a macOS Catalina and can get the board into BOOTLOADER mode to copy the files as directed but nothing seems to update. I'm seeing the green LED blink fast eight (8) times with about a two second pause and I recall seeing that means something is in error.

    Any help would be appreciated.

    Mark G.




    Comments

  • Hi Mark, 

    Sorry for the delayed response.

    What is the thing that you were trying to originally accomplish before attempting the Bootloader update?

    Are you working with MCUXpresso IDE for development by any chance?

    The challenge with some MacOS and latest Windows 10 OS is that it attempts to perform multiple validation reads on MSD OpenSDA which effectively crashes the device. Do you happen to have access to a Windows 7 or 8 PC that you can attempt to use to perform this Bootloader update?

    What is the exact procedure that you following to perform this update?

    Best Regards,
    Zahar
    PEmicro.

  • Hi Zahar.  I'm using mbed Studio.  Before I tried updating the boot loader I was uploading small example programs.  I was having trouble sending data through the serial port and was blinking the LED to confirm I was actually functioning.   Thats when I tried to update the boot loader.  

    Unfortunately I do not have access to a Win7/8 machine. I followed the directions in the download from your site to update the boot loader to the latest version 1.11. That's when I started having problems.

    Thanks,

    Mark G.

  • Hi Mark, 

    Can you please copy and paste the contents of SDA_INF.HTM file that can be found when the board is started in Bootloader mass storage device mode?

    I am curious to see if the Bootloader update actually went through and what version of Bootloader you are currently running.

    Best Regards,
    Zahar
    PEmicro.

  • Sure.  Here you go:

    head>
    <title>OpenSDA Hardware</title>
    <InvalidTag>
    function send_data() {document.forms[0].submit();}
    window.onload = function(){send_data();}
    </script>
    </head>
    <body>
    <form id="form1" name="form1" method="post" action="http://www.pemicro.com/opensda/index.cfm">;
    <input name="tag" type="hidden" id="tag" value="description" />
    <input name="BOARD" type="hidden" id="BOARD" value="FRDM-KL46Z48M" />
    <input name="BOOTVER" type="hidden" id="BOOTVER" value="1.09" />
    <input name="APPVER" type="hidden" id="APPVER" value="0.00" />
    <input name="DUID" type="hidden" id="DUID" value="41233938-ADD681BE-37692809-B860E678" />
    <input name="EUID" type="hidden" id="EUID" value="39C1A239-3F748750-18684A1E-925968D6" />
    <input name="TUID" type="hidden" id="TUID" value="74823938-473281D8-3734B811-B89BE678" />
    <!--474-->
    <input name="TOA" type="hidden" id="TOA" value="86B6E505-393DF9C5-1129F9AB-A30C6E92" />
    <input name="TOA2" type="hidden" id="TOA2" value="86B6E505-0A7CE481-B82900D7-54CA2175" />
    <input name="SUID" type="hidden" id="SUID" value="86B6E505-8D48871F-37239804-8003EC65" />
    <input name="MICROVER" type="hidden" id="MICROVER" value="1.05" />
    <input name="APPNAME" type="hidden" id="APPNAME" value="" />
    </form></body></html>
    <!--424-->

  • Here's an update to this after help from Zahar R. of PEMicro.

    UPDATE:
    I was able to get the boot loader updated to 1.11. I found this forum article
    on a similar issue
    https://os.mbed.com/forum/platform-29-FRDM-KL46Z-community/topic/28423/

    It hinted at following the instructions for the KL05Z boards by using a Linux
    OS to mount and copy the files to the board
    https://os.mbed.com/handbook/Firmware-FRDM-KL05Z

    I followed the commands in a terminal shell on an old laptop with a recent version of Linux.

    I now have a boot loader v1.11 blinking at the normal 1 second interval connected to my
    MacBook Pro.

Add comment


   Want to comment? Please login or create a new PEmicro account.







© 2021 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement