PEmicro logo
Cart New Account Login

Logo image
HomeAbout usProductsSupportForumsBlogCustomer Service

search inside this forum
search inside all forums
Code change to NXP LPC54113J256BD64QL stopped connection with Multilink.
Erskine B. Aug 26, 2020 at 01:41 PM (13:41 hours)
Staff: Mika I.

  • I have a Multilink ACP attached to an ARM NXP LPC54113J256BD64QL using MCUXpresso.  All has been working well for several months. Yesterday I was having issues with an IO pin and changed the IO configuration for several pins. I flashed the target board successfully and after that the Multilink will no longer connect to the development board. I feel I changed something in the configuration for the background debug in the ARM. I attempted to change the code back to the way it was, but there were a lot of changes and I feel I must have missed something. 

    I move to a second board and flashed it successfully. But then when I tried to flash the second time the Multilink would not attach. The events were the same scenario as the first board.

    I have two questions:

    1.   Can the LPC54113J256BD64QL be configured to block the connection of the debugger/flasher?

    2.   Is there a way to recover from such a scenario without replacing the ARM.



    • I resolved the problem, but don’t know which of my actions was the solution.
      First, I updated MCUXpresso to the latest, which included a P&E and LPC5411x updates.
      Second, I used P&E’s progacmp.exe, made the proper selections and erase the target board.
      When I opened MCUXpresso all worked as it should. Both boards now operate.

  • Hi,

    Thanks for reaching out. I'm sorry that you got locked out of your LPC devices.

    Do you remember which IO pin you disconnected? If you disconnected any of the main pins used for SWD (SWDIO, SWDCLK) then that would prevent connection to the Multilink. But since you were able to successfully flash a second board the first time, it does sound like your hardware connections are okay, and it's most likely an issue with the application.

    1. Yes, it's possible that you configured your board such that the Multilink cannot communicate with it. Take a look at the LPC5411x datasheet on NXP's website ( Chapter 7.14 describes how to enable different levels of Code Read Protection (CRP), all of which disable access to the chip via SWD. SWD communication is necessary for the Multilink to access your part.

    2. If you find that CRP is the culprit of your issue, your recovery method will depend on which level of CRP your chips are in. Unfortunately, without SWD enabled, our Multilink won't be able to be used for the recovery method. I would recommend reaching out to NXP for advice on what to do.

    Best Regards,

Add comment

   Want to comment? Please login or create a new PEmicro account.

© 2021 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement