Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

search inside this forum
search inside all forums
How do I fix this PEMicro Debugger hanging status window/Keil crash Issue?
Miguel A. Oct 21, 2019 at 03:08 PM (15:08 hours)
Staff: Gilbert Y.

  • Board:     KL25Z
    MDK: Keil Uvision 5.28.00
    Interface: OpenSDA Embedded Tower Debug

    I used to be able the load code into my KL25Z and the "CPROGACMP Programmer for Freescale" status window would pop up for a second and close and I could see if my code was working on the board and continue to use Keil. Now when I load my code the status window doesn't close and says "Running programming script ..." at the bottom and when I click the close button on the status window Keil also closes. When I reopen Keil it doesn't even remember that I set the debugger to "Pemicro Debugger".

    On top of all this I also have PEMicro and Keil on my laptop and it works normal and I checked that all the debug options were the same. I also tried reinstalling Keil and PEMicro debugger. I'm new to embedded and I haven't the slightest idea how to fix this. Some please give suggestions!!


    • Hi Miguel,

      Thank you for reporting this issue. This issue occasionally appears in Windows 10. The freeze up is caused by an entry that is added to the Windows registry that prevents our progarmcortex_dll.dll file from unloading after CPROGACMP has completed its operations. This issue can be resolved by doing the following:

      1. With administrative access, open regedit.exe . This can be done from the Windows 10 start menu or by opening a Run window and opening "regedit.exe".

      2. Navigate through the folders on the left side to find the following path: Computer\HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers

      3. On the right hand side there should be an entry with a name that matches the file path to the Keil UV4.exe application. The data should say "$ IgnoreFreeLibrary<progarmcortex_dll.dll>". Right click this entry and delete it.

      4. If you have Keil open, please close it and reopen it before testing debug functionality.

      If you could also provide the following information, it would be useful to help us track the source of this issue:

      1. Have you recently upgraded Windows, i.e. Windows 7 to Windows 10.

      2. Is this Keil newly installed? Have you worked with previous versions of Keil on this particular computer?

      Thank you,
      Gilbert Y.

      • Wow, It worked! Thank you!!

        No, I upgraded my computer to win 10 around 4 years ago. Nothing recently though.

        Yes, I installed Keil for the first time, this year Sept 5th so, I'm sure I've only been running the latest version.

Add comment

   Want to comment? Please login or create a new PEmicro account.

© 2021 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement