Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

search inside this forum
search inside all forums
FRDM-KL25Z: An Error occurred while connecting to the interface hardware or target specified in the launch configuration Dialog
jame m. Oct 21, 2019 at 09:00 AM (09:00 hours)
Staff: Zahar R.

  • I have been receiving this error when I try to use the debugger. I tried to copy DEBUG-APP_Pemicro_vxxx.SDA to the bootloader drive, however, nothing happens and the file is removed once I replug the board. I would be grateful if someone could guide me through this.


  • Hi Jame, 

    Can you please start up the OpenSDA board by holding the reset button. The board will enumerate as Bootloader mass storage device with SDA_INFO.HTM file on it. Please open it and paste its contents into your response to this forum thread.

    Which operating system are you working under?

    What is the exact name of the file that you are trying to drop into the OpenSDA board?

    Did you start it up in Bootloader mode, prior to attempting to make this firmware update?

    Best Regards,

    Board Name is: FRDM-KL25Z
    MicroBoot Kernel Version is: 1.05
    Bootloader Version is: 1.09
    Application Version is: 0.00
    DUID is: 17633938-DBAC819C-3765981C-C3ADE678
    EUID is: 2001A239-51CE8732-1866BA07-A9B668D6
    TUID is: 74823938-473281E3-3742C808-CA7AE678
    TOA is: 86B6E505-514B0A93-41E6B687-CB2FF277
    TOA2 is: 86B6E505-0D0C23A7-CDE430D7-78045E2E
    SUID is: 86B6E505-6C47A61D-37239804-8003EC65

    Operating system: Windows 10

    File name that I'm trying to copy : DEBUG-APP_Pemicro_vxxx.SDA

    Yes I tried to copy this file while the board was in the Bootloader mode. This file is necessary to be present in the OpenSDA Board if it has to function as a debugger. However, whenever I try to run the code the error described in the title appears and when I go back in the bootloader mode the file "DEBUG-APP_Pemicro_vxxx.SDA" disappears.

    Thank you for the guidance!


  • Hi Mill, 

    The main issue on the board you are trying to use is that it is programmed with an old Bootloader that does not support Windows 8/10.

    The following blog post provides a step by step instruction on updating the Bootloader first, and then programming it with latest MSD-DEBUG-FRDM-KL25Z_Pemicro_v118.SDA OpenSDA firmware that can be downloaded from our website:

    Please let me know if you have any additional questions after following the steps in this blog post.

    You do need access to a PC running Windows 98/Windows 7 to perform this update.

    Best Regards,

Add comment

   Want to comment? Please login or create a new PEmicro account.

© 2021 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement