Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

search inside this forum
search inside all forums
WIN7&64 & CW5.9 & Multilink
linwang m. Apr 5, 2019 at 04:05 AM (04:05 hours)
Staff: Gilbert Y.

  • CW DEBUG----
    Updating firmware of P&E interface

    Interface hardware detected with old firmware
    Updating ....
    original Firmware: 88.194
    current Firmware: 1.237
    update Firmware:6.15
    and Popup dialog
    error.Check port power,and connections Firmware update failed.Retry?

    I use REV.C and REV.D always the same..


    universal multilink firmware update and architecture selection utility - version 10.17.0.0

    select device show REV
    update firmware green
    What should I do?




    Comments

    • Hi,

      What is the device you intend to program? The Multilink will update to a different firmware depending on what device you are connecting to.

      Regards,
      Gilbert Y.

  • HI Gilbert Y.
    The device I want to program is S12G48
    Firmware updates always go wrong
    I have used software to update the device firmware to RS08/S08/S12(X)Z,cocoldfire+v1
    ffirmware file selection
    automatic
    usbmlfsufbdmens.1017

    update firmware click and turn green

    • Have you applied our patch to your version of CodeWarrior? There may be a compatibility issue with the older CPROG used the base CodeWarrior installation and our newest firmware. Here is the FAQ:

      http://www.pemicro.com/faqs/faq_view.cfm?id=211

      Additionally, we have observed some issues with CodeWarrior and Windows 7 and 10. After applying the patch, if you are still having problems, try moving the CodeWarrior install folder outside of Program Files (x86) and into the root folder of your main hard drive.

      Please let me know if this resolves the issue.

      Thank you,
      Gilbert Y.

  • I reinstalled CW
    download CW51_patch_S12X.rar and PEDrivers_install(12.7.0)

    Backup and replacement unit_12z.dll
    Extract all files from CW51_patch_S12X.rar

    C:\windows Can't find unit_12z.dll
    Search the application directory for the DLL file (unit_12z.dll).

    CW Installation location C:\nxp\CWS12v5.1


    Restart the application debugger and try to debug your target board.

    The problem remains unsolved....

    Can I download the old firmware because it worked before?

    • What you can do to revert to the old firmware is locate the file "usbmlfsufbdmens.0992" that is now in your application folder, and rename it to something like "usbmlfsufbdmens.1020", where the digits after the "." is greater than 1017, since that is the version number of the newest firmware. Then copy that file and move it into the install directory of your multilink_universal installation. When you open the update tool, you should now see the program choose "usbmlfsufbdmens.1020" as the latest firmware. Go ahead and update your firmware and the device will now be reverted to version 9.92.

      Gilbert Y.

  • HI Gilbert Y.

    my problems have been solved, and using old firmware can solve them.

    thinks

    • Glad I could help. If you ever have any other questions, feel free to reach out to us on the forum, through email, or by any of our other support channels.

      Gilbert Y.

Add comment


   Want to comment? Please login or create a new PEmicro account.







© 2019 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement