Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

search inside this forum
search inside all forums
Universal Multilink FX stuck on erase while programming MPC5566 internal flash
Lior B. Mar 5, 2018 at 07:49 AM (07:49 hours)
Staff: Edison T.

  • I am using the MultilinkFX programmer and the ProgPPCNexus program to burn 
    our MPC5566 processors. I connected the device to our card and tried to program it using that software. The programmer reports it connects to the target and then starts erasing the module as part of burning the first file, and then it gets stuck on erase, no matter how much time we wait (hours).
    I tried changing the bdm speed to minimal (31), specifying the internal clock
    speed and using some delays after reset (200-500ms) and it did not help. I also read other posts in this forum and checked the system voltages, which appear to be in order.
    When stuck on erase, the programmer sends a repeated message to the processor,
    and we are not sure what it means.


    • Hi Lior,

      Sorry that you haven't received any responses. Are you still trying to resolve this issue?

      PEmicro Support

Add comment

   Want to comment? Please login or create a new PEMicro account.

© 2019 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement