Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

search inside this forum
search inside all forums
UTest download SPC5
Tirthesh S. Feb 19, 2018 at 05:02 PM (17:02 hours)
Staff: Takao Y.

  • Hello, 

    I can successfully upload from SPC5 for UTEST but when I tried to download that same s19 to another un-programmed micro I get "Error during programming" error.
    Is there some unlock memory feature that I need to run before programming to UTEST



  • Greetings,

    UTEST is OTP, or One-Time Programmable. You cannot erase this region and you cannot write a byte over again once it has been written, even if the value you are writing is exactly the same value.

    There is no such thing as an "unprogrammed" UTEST because the manufacturer writes in this region to set up the DCF Records. Therefore you cannot copy and paste the entire UTEST of one device into another.

    You should try uploading the second micro and then compare the binary files. You will then see which parts are the same and what parts you need to extract.

    Takao Yamada

    • Thank you for quick response. 

      I tried to extract only the 16byte area where there are changes so now my s19 looks like below.
      Still I get ".Error during programing." error.


      Is there some unlocking needed?

      • I had used the SPC5 successfully with UTEST, and just use the "Program Range" to specify only the specific bytes to program that haven't been touched before.

        • Greetings,

          Good tip Colin, I like the way you think.

          Takao Yamada

  • Greetings,

    You may still get a programming error if an attempt to program that region has already been done. The CRC check and attempt to write can only be done once. If you use a fresh silicon you may have better success.

    As Colin said, you can use the program range of your uploaded UTEST binary so that you only program a specific region of your file.

    Takao Yamada

  • Hello Colin and Takao, 

    I am able to write to some UTEST memory address using the Program Range command. I still have issues writing to some memory addresses but I think this is due to OTP areas. I am contacting ST for that item.
    Thank you very much for quick support.

Add comment

   Want to comment? Please login or create a new PEMicro account.

© 2019 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement