Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service


Please accept the use of cookies on our site

At PEmicro we use web browser cookies in order to provide you with an enhanced experience and in order to be able to do things like shopping cart processing and identify you when you login to our website.

Click here to accept



search inside this forum
search inside all forums
Use Multilink universal FX to program flash with Codewarrior V5.9
Stefano N. Feb 19, 2018 at 12:35 PM (12:35 hours)
Staff: Takao Y.

  • Greetings,

    We used for many years the blue programmer Multilink for programming Coldfire trough USB with both Codewarrior IDE V5.9 build 3024 and V5.9 build 5293 and all works well (BDM connection with the target).

    Now we approacing to use the new programmer Multilink universal FX (Rev B.):

    Is there any way to use it with our owned version of Codewarrior IDE?

    Thanks for the support
    Best regards

    Giuseppe T.




    Comments

  • Greetings,

    You can follow my FAQ about how to patch the software yourself to update the files to allow you to use newer hardware:
    http://www.pemicro.com/faqs/faq_view.cfm?id=211&menu_id=faqs


    Takao Yamada

    • Greetings,

      thank you for your fast response, i've installed the patch for coldfire and the multilink FX drivers, afterwards i've tried to erase the MCF52259 and a window for update the programmer firmware appears (only the first time).

      When i click on erase, the software return: initialization failed (every time).

      It seems that the programmer is now recognized (after the patch), but something go wrong.

      We are programming MCF52259 microcontroller and the initialization file MCF52259.cfg and the setting file MCF52259_INTFLASH.xml are the same that we using for the old coldfire programmer.

      Thanks in advance for the answer
      Greetings
      Giuseppe T.

  • Greetings,

    Look into the project's settings -> Remote Debugging -> Edit Connection... -> and increase the speed around 20. Then attempt again.


    Takao Yamada

    • Greetings,

      After setting speed at 20 all works well, thank you so much!

      Giuseppe T.

Add comment


   Want to comment? Please login or create a new PEMicro account.







© 2018 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement