Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

search inside this forum
search inside all forums
Cyclone pro on win7
PierGiovanni G. Jan 24, 2018 at 08:34 AM (08:34 hours)
Staff: Takao Y.

  • I have installede CodeWarrior6.3 on Win7 64bit.
    All seems to be ok, but loading target for debugger does not work.
    Message: CycloPro/Max Usb driver dit not initialize (20000021)
    Library=WDAPI900.DLL
    How can I continue to use CodeWarrior ?
    Your Sincerely,
    Pier Giovanni




    Comments

  • Greetings,

    You should have checked our most popular FAQ, which is here:
    http://www.pemicro.com/faqs/faq_view.cfm?id=211&menu_id=faqs


    Takao Yamada

    • I have already executed the file PEDriver_install.exe and applied the parches from CW63_patch_S08.RS08.CFV1 as in the notes for installation, but the problem is not solved.

  • Greetings,

    Did you make sure to follow my readme.txt instructions? Sometimes customers replace the entire support directory instead of merging. Make sure you dumped the new files into the original folder.

    Within device manager, does your cyclone show up? Under Jungo you should see WinDriver and Cyclone/Tracelink.


    Takao Yamada

    • Within device manager under Jungo Isee WinDriver and USB Multilink 2.0
      I have unzipped the file and then copied the files from folder patch in folder prog/P&E
      I am using an USB Multink Interface and a Multilink Universal

  • Greetings,

    The error message indicated Cyclone pro/max, so that was my assumption. Good, the device manager sees your hardware.

    When you start a debug session and the connection assistant pops up, are you able to see and select your multilink?

    Also, just to remove any other factors I would like you to force update your multilink universal with the latest firmware using the firmware updater utility:
    http://www.pemicro.com/downloads/download_file.cfm?download_id=346


    Takao Yamada

  • When I start the debug session I see the pop-up 
    Interface USB HCS08/HCS12/CFV1 Multilink-USB port
    Undetectred. Disconnect/connect USB Cable. Click Refresh list FAQ #29
    And the message
    Message: CycloPro/Max Usb driver dit not initialize (20000021)
    Library=WDAPI900.DLL

  • Greetings,

    When you use the firmware updater utility I posted, are you able to see your multilink universal hardware? If so, then we know your hardware and drivers are good and the issue is the software side.

    Could you go to support page -> Support requests to create a ticket for me and zip up the P&E support folder within Codewarrior and attach it. I want to see what is there and confirm that all the right files are present.


    Takao Yamada

Add comment


   Want to comment? Please login or create a new PEMicro account.







© 2018 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement