Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

search inside this forum
search inside all forums
Error 18 during scipt
Dhing F. Jan 17, 2018 at 04:58 PM (16:58 hours)
Staff: Takao Y.

  • C:\PEMICRO\PROG12Z\CPROG12Z.EXE ? 1 IO_DELAY_CNT 14 C:\pemicro\veltron2c\v2ctest\v2ctest.cfg Interface=USBMULTILINK PORT=USB1
    if errorlevel 1 goto bad
    goto good
    -----script file -----
    CM c:\pemicro\prog12z\9s12dt128_128k.12p
    SS c:\pemicro\veltron2c\v2ctest\v2ctest110.phy

    Everything are ok except during PM command. The screen flash like this...

    Checking range of S records. Checked
    Programming Address $0E0000Error during programming
    Error 18 during script !

    Sometimes if I try so many times,everything goes ok, re-try it and it fail and the same "Error 18 during the script"
    Any help are greatly appreciated..


  • Greetings,

    Try debugging your problem using PROG12Z. Are you able to replicate the issue?
    If you are able to program in PROG but not in CPROG, then we can start looking into the BAT or CFG file you are using.

    Takao Yamada

    • Hello Takao Yamada,
      I don't have PROG12Z. This things happened when my computer failed to boot up. So I just remove the hard drive which was ok and installed to a new computer.Then this "error 18 came out".Here are the properties of my interface adapter.I don't know if this may help you or some idea about this driver.

      USB Multilink 2.0 "driver ver. Driver date:3/27/2007
      Windrive "Driver Ver. ; Drive Date: 3/27/2007
      USB Multilink HCS08/HCS12 ColdFire V1 : Part #USB-ML-12E

      My New/Old computer was Inter Core Duo CPU :E7500@2.93GHZ Window XP

      This was installed by our customer and I'am not tech savvy when it comes to software. Do you have any idea how could I fixed this problem. Sometimes it work for maybe 30x try then failed after I try it again. Is there some some timing issue,missing files or bad adapter. I tried to my other interface adapter and still the same problem.

      I do appreciate for the help you extend to me


  • Greetings,

    If you have CPROG12Z, then you have PROG12Z. Check your C:\pemicro\prog12z directory and you will find the software I need you to use.

    Inconsistent errors are difficult to debug and right now there are not enough information to fix this issue.

    One thing you may want to try is program the exact same board 30 or more times and see if the issue occurs. If not, then the issue is not in software or drivers. It is most likely hardware when you are switching between boards. You may want to check your ribbon cable for problems.

    Takao Yamada

  • Good Morning Takao,

    I try to locate on C:\pemicro\prog12z and there's nothing there, on it't folder was only CPROG12Z.EXE and some other files.I try to program one good board that was my "Gold Board". It just erase the loaded program and "Error 18 come out". try it again on the same board, Failed ..try it again failed..and keep on trying until it pass (maybe 30 or more times).After it pass I try to load the program on the same board again and it Failed,and I had to do it the same thing again until it pass.I'm just testing only one known good board. I checked my cable and it was ok. Try on the other interface adapter and it failed the same "Error 18 "

    I do appreciate for taking your time on this matter


  • Greetings,

    That means someone gutted your PROG12Z folder to only have the CPROG software. Which is unfortunate.

    You may want to change the IO_DELAY_CNT setting within CPROG. Right now you have it set to 14. Try a higher number like 50. See if this gives you better results:

    C:\PEMICRO\PROG12Z\CPROG12Z.EXE ? IO_DELAY_CNT 50 C:\pemicro\veltron2c\v2ctest\v2ctest.cfg Interface=USBMULTILINK PORT=USB1

    Takao Yamada

  • Hello.
    I change the IO_DELAY_CNT from 14 to 50, it get an error #34 "Can't enter on background mode. Change it back to 14 and it goes on the same problem "Error 18.
    I edit the cfg script file and add another command VM (verify module) before PM command..Look like this

    CM c:\pemicro\prog12z\9s12dt128_128k.12p
    SS c:\pemicro\veltron2c\v2ctest\v2ctest110.phy

    It flash me an error on the screen like this.
    CMD> VM
    Checking range of S record . Checked
    Verifying Address $0E0000. Verify Error at Address $0E0000
    Byte in Module is $FF and should be $34
    Error 3 during the script

    I don't know if these make sense to you.

    Thanks again

  • Greetings,

    VM should be at the end. VM indicates you want to verify that the programming was done correctly. You have it set before the programming, so it will fail. The chip has not been programmed yet.

    Takao Yamada

Add comment

   Want to comment? Please login or create a new PEMicro account.

© 2019 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement