Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service


Please accept the use of cookies on our site

At PEmicro we use web browser cookies in order to provide you with an enhanced experience and in order to be able to do things like shopping cart processing and identify you when you login to our website.

Click here to accept



search inside this forum
search inside all forums
Multilink ACP connection to Target
Gary C. Jan 10, 2018 at 03:03 PM (15:03 hours)
Staff: Takao Y.

  • I have a Multilink ACP and am wiring it to my hardware for Debug through the 20 pin connector.
    I am using an NXP KE04Z8 ARM processor and am Utilizing Codewarrior 10.6. I have TVCC connected to my hardware's VCC(+5v), SWD_DIO and SWD_CLK connected appropriately. Do I connect my KE04Z8's RESET(pin 1 on my KE04Z8) to TRST or RESET on the 20 pin connector? TIA.




    Comments

  • Greetings,

    Connect to RESET, not TRST. We do not use TRST.


    Takao Yamada

  • Thanks for your assitance Takao.
    I still can't get my interface to work.
    I am using the PnE U-Multilink Codewarrior configuration.
    Device manager sees the USB Multilink but Codewarrior IDE can't find it.
    Tried the slowest SHIFT CLOCK but it doesn't help.
    I have tried testing the MULTILINK ACP on the IAR platform and it works fine.

  • Greetings,

    Your Codewarrior cannot see the multilink? Try updating your Codewarrior to the latest version. I believe it is now at 10.7 or 11.0. Then try again. The multilink ACP is a newer hardware so this could be a hardware/software compatibility issue.


    Takao Yamada

  • Thanks Takao,
    It seems that the pegdbserver is not launching with either KDS or CW ide's.
    If I select Cyclone Pro.
    Fails because I do not have Cyclone Pro, then select Multilink refresh and try again, it works!
    I think it's the failure to launch the pegdbserver when I simply start with the MultiLink.

  • Takao,
    I updated KDS and now all is well!
    Thanks for your assistance!!

Add comment


   Want to comment? Please login or create a new PEMicro account.







© 2018 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement