Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

Please accept the use of cookies on our site

At PEmicro we use web browser cookies in order to provide you with an enhanced experience and in order to be able to do things like shopping cart processing and identify you when you login to our website.

Click here to accept

search inside this forum
search inside all forums
MC9S08DZ60 programming connection issue with USB multi link universal
anuj t. Nov 28, 2017 at 12:42 AM (00:42 hours)
Staff: Takao Y.

  • Hello

    I am using the USB multilink universal programmer to program the MC9S08DZ60
    device. Code warrior version is 10.2 and am using the Flash file to target for directly program the S19 file. Am using the EVM9S08DZ60 STARTER KIT
    my system is windows 7 64-bit

    all drivers are installed ok and programmer is working fine as i am able to program a M5232 device with the same programmer and same flash file to target utility using code warrior 10.2

    when i click erase whole device on the utility then after the code warrior initiates the process and a message is displayed to power off and on the board and click ok to continue, basically the power cycle message is displayed.

    when i do the steps as described in the message another box pops up asking you to retry or abort

    i have tried this repeatedly and same issue is observed every time.
    i also tried same procedure with earlier usb multilink interface but i get the same result every time

    please help me out with this issue.




  • Greetings,

    The Flash file to target feature is actually not using our software to program the device.

    I advise that you create a fresh new project for the DZ60 in CW10.2 and attempt to debug the project. That uses our software and you should have no issues programming your device. Let me know if you were successful.

    Takao Yamada

    • Hello Takao,

      Thank you for the reply

      The issue is resolved. The issue was with the cables used. I tried 2 cables and both were not working.

      but now when i use the erase whole device from Flash file to target
      I get erase command succeeded but am getting Blank check command failed error

      but when i use the erase and program option i do not get any error and the device is programmed with the specified S19 file



Add comment

   Want to comment? Please login or create a new PEMicro account.

© 2018 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement