Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

search inside this forum
search inside all forums
"Target DLL has been cancelled" error erase/program nRF52 Keil uVision 5
Bruno S. Aug 23, 2017 at 10:20 AM (10:20 hours)
Staff: Zahar R.

  • Hi,

    I am working with a Bluetooth module from u-blox(NINA B112-00B) which contains a nordicSemi board nRF52832 with a Cortex M4 processor. I am having this "Target DLL has been cancelled" error while trying to erase or program it using Keil uVision IDE.

    I am using Keil IDE uVision v5.24.2.0 and a PE Micro Multilink Universal rev b connected via port G - mini-10 (because i only need the SWD pins to flash the module).

    I've looked into some other topics and here some information that might help:

    Operating System: Windows 10

    While in uVision these are my config: Flash->Configure Flash Tools...->Debug->Use: PEMicro Debugger->Settings:
    -Interface: USB Multilink, USB Multilink FX, or Embedded OSJtag
    -Port: USB1 : Multilink Universal Rev B (PE5655164)
    -Device: NRF52832-CIAA
    -Debug Shift Speed = (0) : Multilink = 1.00Mhz, Multilink FX = 25.00Mhz, OSJTAG = 0.25Mhz
    [checked] Use SWD reduced pin protocol

    on my {Keil_Installation_Folder}\ARM\PEmicro\P&E folder, i got the
    icdarmcortex_dll_v614.dll and progarmcortex_dll_v614.dll files and also the icdarmcortex_dll_v603.dll and progarmcortex_dll_v599.dll files

    Pemicro_ArmCortexInterface.dll is located on my {Keil_Installation_Folder}\ARM\PEmicro folder

    I've downloaded the supportFiles_ARM pack provided by PEMicro website and the Keil_PnE_Support_install_b161130.exe file

    Also tried to flash the module via PROGACMP software, but it stopped answering after an erase attempt.

    Please, how do i fix this problem?


  • Hi Bruno, 

    I noticed that our online Keil download was not updated with the latest. Our web team just corrected this mistake. Please download the latest Keil support installer b170726 and give it a try.

    Best Regards,

    • Hello Zahar,

      Thanks for the support in first place, but i downloaded and installed the driver you linked and I'm still getting the same error. I just need to run the driver and choose the {Keil_Installation_Folder}\ARM\PEmicro\ folder, right? Do i need to set any other configuration inside the uVision IDE?

      One other thing I'd like to ask, it's about the PROGACMP. Is it possible to flash program our nordicSemi board on our PROGACMP version? Or is there any manufacturer issue, since it's a Freescale Programmer?

      This is a print screen of our PROGACMP running

      Thanks in advance,


  • Hi Bruno, 

    What version of PROGACMP are you running? The latest versions of this product should allow you to program any ARM device that we currently support, including NordicSemi nRF52832.

    Below is a link to a complete list of ARM devices that our latest ARM PROGACMP software and Eclipse GDB plugins support:

    When you install the latest Keil deliverable from installer I shared, please only enter the root directory ({Keil_Installation_Folder}) of where your Keil IDE is located. The installer will place P&E deliverable into correct location within Keil IDE and you should be up and running.

    Best Regards,

    • Hi Zahar,

      I'm running PROGACMP v3.00.00.22, is there any version update available?

      I downloaded the support files, and tried to erase the module again, but i'm still getting the same error.

      I also installed again the installer you shared and tried to erase the module through Keil IDE, but nothing's changed.



  • Hi Bruno, 

    Just want to quickly follow up to see if you were able to resolve a problem connecting to your nRF52832 device using Multilink Universal FX RevB. Please let me know.

    Best Regards,

Add comment

   Want to comment? Please login or create a new PEmicro account.

© 2019 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement