Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service


Please accept the use of cookies on our site

At PEmicro we use web browser cookies in order to provide you with an enhanced experience and in order to be able to do things like shopping cart processing and identify you when you login to our website.

Click here to accept



search inside this forum
search inside all forums
Cyclone Pro/Max USB driver did not initialize (20000021) Library=WDAPI900.DLL
Diego L. Jun 2, 2017 at 10:36 AM (10:36 hours)
Staff: Takao Y.

  • I have a universal programmer multilink Rev. c, I have installed and running cw 6.3 on Windows 10 64-bit, and download the driver the universal multilink PE, but since the firmware update utility achievement last detect programming and update, but since the CW tip when I schedule jump me the error that does not detect it, throws the error already without connecting the tip of the usb programming and although connect and put refresh continues with the same error :
    Cyclone Pro/Max USB driver did not initialize Library = WDAPI900 (20000021). DLL
    I need help




    Comments

  • Greetings,

    Did you do a search in our forums or FAQ of this problem? It is a very popular issue and could be easily solved. I have written an FAQ on this:
    http://www.pemicro.com/faqs/faq_view.cfm?id=211&menu_id=faqs

    Please try the patch and it should solve your issue. Also make sure you are using the latest drivers:
    http://www.pemicro.com/downloads/download_file.cfm?download_id=53


    Takao Yamada

    • Thank you.
      But I have already installed
      P&E Hardware Interface Drivers, Version 12 (Win XP/Vista/7/8/10).
      and
      Patch for CFV1/S08/RS08/MON08 3rd Party Software

      And it remains the same

      • The error appears before connecting the tip into the usb of the pc, should a driver be evil, or some .dll

  • Greetings,

    Did you replace the entire P&E folder, or did you merge? If you replaced the entire folder then you may get this problem to occur. Make sure you only add the new files into the P&E folder.


    Takao Yamada

    • If I only add files, delete nothing of that folder

  • Greetings,

    Did you make sure to keep a backup of the original P&E folder? If so, make a copy of the backup P&E folder and retry the patch again. If you did not, you may need to reinstall Codewarrior and try again.


    Takao Yamada

    • Yes I have the original folder

  • Greetings,

    Any update on this?


    Takao Yamada

  • I have a universal programmer multilink Rev. c, I have installed and running cw 6.3 on Windows 10 64-bit, and download the driver the universal multilink PE, but since the firmware update utility achievement last detect programming and update, but since the CW tip when I schedule jump me the error that does not detect it, throws the error already without connecting the tip of the usb programming and although connect and put refresh continues with the same error :
    Notice - Cyclone Pro/Max USB driver did not initialize. (20000007)
    - Library=WDAPI900.DLL

    I need help

    Already re-install CW, update them, the error is given without connecting the universal multilink in the usb, also add the files in P & E
    Patch for CFV1 / S08 / RS08 / MON08 3rd Party Software
    And also undo the PE driver 12.7.0.0
    And it keeps throwing the same error.
    I need help.
    If I program mics by MON08 it works correctly, but anyone who wants to multilink before connecting it to the usb already fails.

  • Greetings,

    Use the new firmware config utility here:
    http://www.pemicro.com/downloads/download_file.cfm?download_id=346

    Are you able to see the multilink and force update it to the latest version? If so then that means the firmware and USB drivers are fine and the DLLs in the CW6.3 patch are out of date.


    Takao Yamada

Add comment


   Want to comment? Please login or create a new PEMicro account.







© 2018 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement