Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service


Please accept the use of cookies on our site

At PEmicro we use web browser cookies in order to provide you with an enhanced experience and in order to be able to do things like shopping cart processing and identify you when you login to our website.

Click here to accept



search inside this forum
search inside all forums
Multilink in Windows 10 Virtual Machine
Francis C. May 2, 2017 at 04:30 PM (16:30 hours)
Staff: Kevin M.

  • Hello,

    I am using Virtualbox with a MultilinkACP and I have the exact same problem that a VMWare with a Multilink Universal user has described in this thread (it is seen in the IDE only for a very short time at connection)
    http://www.pemicro.com/forums/forum.cfm?forum_id=8&forum_topic_id=5338

    Are the Multilinks supposed to work properly with Virtualbox and Window 10 32bits as guest OS (Ubuntu 16.04 host)

    Thank you




    Comments

  • Francis,

    Do other USB devices work normally?

    Best,

    Kevin

    • Yes. All other USB devices work properly.  I even have a Segger J-Link that works properly through the VM...

      Could it be something related to Multilink ACP driver vs Multilink Universal driver?

      Thanks

  • Francis, I do not think it has to do with the type of multilink. 

    Does the multilink appear in the guest machine's device manager?

    • Yes Kevin, I have under Jungo:
      - USB Multilink 2.0, 2/18/2016, ver. 12.3.0.0, VID_1357 PID_0503 REV_0910
      - WinDriver, 2/18/2016, ver. 12.3.0.0, WINDDRVR6
      Both have been installed by Driver Manager with status 0x0.

      Thanks

  • Okay that is good.

    Are you using KDS? Can you try updating to the latest version of the plugin? www.pemicro.com/eclipse/updates ?

  • Yes I'm using KDS with plugin version 2.9.6.201704281541.
    I have successfully installed all the same on another computer (no VM)

    Thanks

    • I have also tried with CodeWarrior just to compare, and it doesn't see it either

    • In fact, the Multilink ACP can be seen by either KDS and CodeWarrior a split second on connection, depending upon I hit Refresh at the right time.   But when I hit Refresh again, it's not there anymore.

    • I have tried uninstalling the driver and uninstalling and reinstalling the PEmultilink_universal_install.

      Thanks

      • ... to no avail

  • Francis,

    Please check your email, I just sent you a file post

    • Hi Kevin,

      Same thing: if I hit Refresh List and plug in the MultilinkACP half a second after, the Connection Manager will see it. And if I hit Refresh List again, it says Undetected. But it still can be seen in Windows 10 (32bit) device manager.

      Thanks

  • Francis,

    One more thing to try: Make sure the guest additions cd has been installed

  • Francis,

    Any update on the issue?

Add comment


   Want to comment? Please login or create a new PEMicro account.







© 2018 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement