Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

Please accept the use of cookies on our site

At PEmicro we use web browser cookies in order to provide you with an enhanced experience and in order to be able to do things like shopping cart processing and identify you when you login to our website.

Click here to accept

search inside this forum
search inside all forums
Problems with Keil and FRDM Board
Martino D. Jan 16, 2017 at 10:16 AM (10:16 hours)
Staff: Zahar R.

  • Hello, 
    I'm trying to use MDK Keil 5.2 in LiteVersion (evaluation) and I have problems to upload Fw on my board. After compiled the fw I launch the Download Procedure and the error is "Error: Flash Download failed - Target DLL has been cancelled".
    In option I think I had set the option to do it. In Debug Tab i chose PEmicro Debugger and .\pemicro_connection_settings.ini . In settings i chose
    Interface: USB Multilink..... Port: USB1 Multilink Universal Rev C. I think my options are why It doesn't work?

    I hope in your help
    Thank U All



  • I have the same problem, but I even choose the "open SDA XXX " for the interface, and ended up with the same error message.

  • Yes Gary,
    I choose also with your same option but it doesnt' change anything

  • I solved the problem! I installed the P&E Support linked here in the correct path of Keil. The error is that i installed in another folder of a previous version of Keil. Thank you. Bye 


    • Hi Martino,

      I got things going further, but I just met another new issue.
      whenever I downloaded the code and prepared to do the debugging, it can never run to the main() and hang there, always saying " CPU reset by debugger", and I was just running the PE micro example projects without changing anything.

      If I do a STOP debugging, the pointer is always at hardfaulthandler...

      anybody met this problem before?


  • oops, same here, issue is resolved.

  • PEmicro debugger can not stop at main(), even running the PEmicro example code on freedom board.

    Does anybody know why?

  • it has " CPU reset by debugger" in message window, and system is stall, you can not single step or step over, only can stop it and reset it.

  • Hi Gary, 

    Which Freedom board/target microprocessor are you working with?

    Best Regards,

Add comment

   Want to comment? Please login or create a new PEMicro account.

© 2018 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement