Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

Please accept the use of cookies on our site

At PEmicro we use web browser cookies in order to provide you with an enhanced experience and in order to be able to do things like shopping cart processing and identify you when you login to our website.

Click here to accept

search inside this forum
search inside all forums
CONVERT fails in conversion .hex
Robert S. Dec 15, 2016 at 03:32 PM (15:32 hours)
Staff: Takao Y.

  • Using CONVERT on one of our .hex files the file gets "converted" to S19 however, it fails to program properly.  
    Takes 5 minutes and fails verification step.

    I used a j-link based software. It worked.
    Converted to S19 using the jlink based software and the S19 programmed using my Cyclone Universal.
    The cyclone programmed and verified program within 20 seconds.

    I'd prefer to use and stick to PEmicro tools. The Cyclone is a great piece of hardware. But, I'm unsure how to move forward with this issue. Please advise


  • Greetings,

    Have you tried just flash programming the HEX file without conversion?

    Do you know if your HEX file is in extended addressing mode?

    Takao Yamada

    • Yes I have.  This has worked in the past.  However, it does not work in this application.  I'm unsure what extended addressing mode is or how it affects programming.  I'm not necessarily a firmware engineer.  I'm on the production engineering side.  Would it be possible to have a discussion either over email to better help?  
      Please and Thanks for you timely reply!
      Jarrid Stairs

  • Greetings,

    Could you go to Support page -> Support requests and submit a ticket. There you can attach your HEX file and I will take a look at whether your hex file is in extended addressing mode. Then I will use GNU objcopy tool to convert it to an s-record file. I can give you instructions on how to do this conversion yourself for future use.

    Takao Yamada

  • Ok support request submitted

  • #24459

  • This Issue was resolved with help from Takao.  

Add comment

   Want to comment? Please login or create a new PEMicro account.

© 2018 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement