Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

Please accept the use of cookies on our site

At PEmicro we use web browser cookies in order to provide you with an enhanced experience and in order to be able to do things like shopping cart processing and identify you when you login to our website.

Click here to accept

search inside this forum
search inside all forums
Cannot enter BDM mode on censored MPC5676R device with erased boot
Rincy R. Sep 22, 2016 at 04:34 PM (16:34 hours)
Staff: Takao Y.

  • Hello,

    I am trying to program boot block (that has been erased accidentally) of an MPC5676R device which has a password locked JTAG port. I am using P&E USB Multilink. Both the blue and orange LEDs on the Multilink are lit and the voltages measured on the JTAG pins are as follows.
    TDI 0V*
    TDO 0.6V*
    TCK 0V*
    EVTI 3.3V
    RST 4V (should be 5V but that shouldn't affect the micro)
    TMS 0V*
    VDD 3.3V
    RDY 3.3V
    JCOMP 3.3V
    *except voltage variations seen when the Multilink attempts to connect to the micro

    I tried using CodeWarrior cw_icdppcnexus.exe and cw_progppcnexus.exe to connect to the micro after entering the JTAG password under "Advanced" menu.
    With the debugger (cw_icdppcnexus), I get a message "Attempting to uncensor device, debugger retrying force to background mode".
    With the flash programmer (cw_progppcnexus), I get a message "Error in ONCE status register during instruction execution. Not able to access processor. Try a software reset." If I don't input any password, the message reads "Can not enter background mode".
    In both the cases, the USB-ML-PPCJTAG is detected.

    Could you please help me with this issue?




  • Greetings,

    Before the boot block was erased, did you ever get the USB ML PPCJTAG working on this device? Is this your first attempt or you are only seeing this problem because the boot has been erased?

    Takao Yamada

    • I tried using the P&E Multilink only after the boot block was erased.

  • Greetings,

    So we do not know if the problem you are facing is due to the boot block being erased. So we need to take a step back and get a working condition first.

    Do you happen to have a MPC5676R chip that is fresh from manufacturing? Do you have any other MPC5xxx devices that you could test your hardware and software setup? I need you to run this test to ensure your multilink is in good condition and that you have the right setup. Then we can narrow our problem down to the boot block. But right now we have too many unknown factors.

    Takao Yamada

  • Greetings,

    Any update on this?

    Takao Yamada

Add comment

   Want to comment? Please login or create a new PEMicro account.

© 2018 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement