Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service


Please accept the use of cookies on our site

At PEmicro we use web browser cookies in order to provide you with an enhanced experience and in order to be able to do things like shopping cart processing and identify you when you login to our website.

Click here to accept



search inside this forum
search inside all forums
Flash Erase Failed. Result = $882 Firmware update failed.
. Jun 25, 2016 at 12:21 PM (12:21 hours)
Staff: Kevin M.

  • I bought a PE micro and installed the software on my computer.  I started the software and clicked connect, but I get an error that says "Flash Erase Failed.  Result = $882 Firmware update failed."




    Comments

  • Hi,

    What interface are you using? (i.e. cyclone max, multilink universal)

    What P&E software are you using?

    Has this interface ever worked?

    • Multilink Universal

      progppcnexus software

      This is a brand new PE micro. I had another PE micro that worked, but it got damaged when I shorted out the fixture it was connected to. So I had to buy a new one.

    • I also didn't receive the installation CD with my new PE micro, just a documentation and utilities CD.  So I am using the software that was already installed on my computer that I used with my old PE micro.  Should I have gotten new installation software?

  • My suspicion is that the unit may be damaged. Did you ever get this working?

    • Yes.  I updated the firmware and it started working.

Add comment


   Want to comment? Please login or create a new PEMicro account.







© 2018 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement