Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

Please accept the use of cookies on our site

At PEmicro we use web browser cookies in order to provide you with an enhanced experience and in order to be able to do things like shopping cart processing and identify you when you login to our website.

Click here to accept

search inside this forum
search inside all forums
Janet C. Apr 27, 2016 at 07:58 PM (19:58 hours)
Staff: Kevin M.

  • I have a USB-ML-CFE Rev C that has worked fine with Coldfire boards in the past.  Recently, I downloaded the latest multilink universal drivers from PE Micro and I cannot connect to my Coldfire 5485 board. I get the yellow and blue LED lights going, but the target rst command fails.  Do I need to get the latest USB multilink for Coldfire and if so do I need special cables? Thanks!


  • Greetings,

    You do not need special cables, and the multilink universal should work just fine.

    What you need to do is make sure the universal is configured to work with ColdFire devices. Download that CD that came with it and run the firmware updater utility. Change the firmware to support ColdFire and run your test again.

    Takao Yamada

    • Ok, I haven't received the new part yet, but will run the firmware updater utility and configure the universal for Coldfire when I do get it ( probably next week). Thanks!

  • Greetings,

    Just so I understand you clearly, which hardware are you using, the USB MLCFE, or the Multilink Universal. These are two very different hardware.

    Takao Yamada

    • I am using the USB-ML-CF Rev C. Very old, like 10 years old, which is why I think getting a new USB multilink will work better with the current drivers. Thanks!

  • Greetings,

    The rev C should work just fine. I still use it on my Windows 7 64-bit machine.

    What software are you using and its version if you can find it? The problem may be the software you are using is too old and may have issues working on the latest operating systems.

    Takao Yamada

  • Hello,  I am using Multi 5.06 and a 5485 coldfire board via USB multilink (USB-ML-CF Rev C). 

    Two questions:

    #1. The drivers installed just fine and show up in my Device manager screen (on Win 7). Both blue and yellow lights are on. When I gry to download my program, I get this error:

    Executing setup script: C:\Perforce_Workspaces\NetX_Duo_Dev\release\threadx\cf5485evm.mbs
    Failed to reset target.
    Error: General Error
    Command 'rst' failed.
    Aborting target setup owing to command failure:
    target rst
    in stack:
    Script C:\Perforce_Workspaces\NetX_Duo_Dev\release\threadx\cf5485evm.mbs:3
    Failed executing setup script!
    load: Download failed.

    I am using the latest PEMicro drivers; I haven't configured the drivers for Coldfire or modified them in any way. I ran the PEFirmwareUpdater.exe as well.

    I ordered a new multilink thinking the USB-ML-CF was not supported by the drivers but you indicated it should work fine. What should I try next, or what other information do you need from me?

    #2. The installation instructions state that Coldfire devices require a CABLE-CF-ADAPTER, but above you indicated I would not need any special cables. Do I need to order this part?


  • Greetings,

    1) You need to contact GreenHills to see if they have any software updates that can support your P&E interface. You could try using my patch but I cannot guarantee it will work on Multi.

    2) No, you do not need any extra hardware. You are not using the MCF5206 or MCF5272.

    Takao Yamada

    • Hi Takao

      I did the driver test and it informs me I am missing peusbb09.dll and peusba09.dll. The PeMicroDriver.sys file is also missing. Are these files necessary for the latest multilink bdm on the Coldfire target?

      If yes, where can I obtain them, if they were not automatically installed with my multilink installation CD (just ordered the newest one two weeks ago).

      To refresh you, I use Windows 7.

      Also I confirmed from Greenhills Multi that the PE script I have for starting up the board is the latest.


  • Janet,

    Sorry for the delay in response here. Has your issue been resolved?



Add comment

   Want to comment? Please login or create a new PEMicro account.

© 2018 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement