Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

Please accept the use of cookies on our site

At PEmicro we use web browser cookies in order to provide you with an enhanced experience and in order to be able to do things like shopping cart processing and identify you when you login to our website.

Click here to accept

search inside this forum
search inside all forums
CyclonePro not working with Ethernet connection
Bartlomiej W. Apr 7, 2016 at 05:00 AM (05:00 hours)
Staff: Takao Y.

  • Hello,

    I am trying to communicate with CyclonePro using Ethernet connection and the following settings (based on the CyclonePro manual):

    - Windows 8, Firewall ON (corporate machine), ConfigureIP installed under Administrator mode
    - IP:, Subnet mask:, gateway not set

    - Connected to the PC via crossover cable, directly to the Ethernet port.
    - IP:, Subnet mask:, Gateway:
    - Firmware v. 8.66, FPGA v. 1.6 (updated today with the use of the Cyclone Pro Image Manager).

    I cannot communicate with CyclonePro, neither via ConfigureIP nor with ping. The activity (green) LED of the Ethernet port never blinks.

    Please help,



  • Greetings,

    Just rule out the cyclone being defective, are you able to connect to it using USB or other methods? Also, have you tried using the cyclone with an ethernet switch?

    I will look into replicating this issue on my computer and let you know if I see any problems.

    Takao Yamada

  • Greetings Takao,

    thank you for your quick reply. The device works just fine via USB. I have tried to use it with an ethernet switch, i.e. via our corporate network. It did not work either.

    Actually, my primary goal is to make it work via the network. I tried the direct PC connection to simplify the problem, even though, according to our IT department, the network should be setup correctly to support the device.

    I suspect damaged CyclonePro ethernet port.

    I am looking forward to hearing from you.

  • Greetings,

    Ok, let us not go down the cross-over cable method since that is not your intended solution.

    Note that ping will not work on cyclones. It does not understand ICMP packets.

    1) Is this cyclone pro new? If not, has the Ethernet on the cyclone work in the past?

    2) If you connect the cyclone to a network switch, does the yellow and green LEDs light up and show some kind of activity? If still no green LEDs, that does sound like a problem on the Ethernet port.

    3) Is the network switch on the same network? You may want to check if you need to set up a gateway on your PC and change the gateway on your cyclone.

    Takao Yamada

  • To answer your questions:

    1. It is fairly new (around 8 mnths old). I have never tried to work with it via Ethernet before.

    2. When connected to a switch or directly to PC (via crossover cable), both LEDs are always on (amber + green). No blinking.

    3.Yes, the gateway and mask addresses are identical on the PC and on CyclonePro


  • Greetings,

    2. Try connecting your cyclone to a switch. Then check the LEDs. See if there is any activity. You should see some as the Ethernet switch tries to communicate and enumerate it into the network.

    Takao Yamada

    • Hello Takao,

      I did connect cyclone to a switch. Both LEDs are on, no other activity, no blinking.


  • Greetings,

    If you are within the USA I can suggest you to send your cyclone to our facilities in Boston and we can test out the unit for Ethernet capabilities. If it indeed has Ethernet port issues, we can repair or replace the unit at a cost.

    Another suggestion is to get a packet sniffer like wireshark and monitor between your switch and the cyclone. You can use a utility like image manager and click the refresh button. This sends a broadcast from your computer out to the network and your cyclone should respond back.

    If data is going only towards the cyclone but not responding back, then you may have a bad cyclone. If data is going both ways but packets are blocked or not reaching their destinations, then you still have a network configuration issue.

    Takao Yamada

  • Hi Takao,

    good idea (with WireShark). I will try it early next week.

    Have a good weekend!

  • Greetings,

    Were you able to resolve this issue?

    Takao Yamada

  • Hello Takao,

    not really, no. The Ethernet port simply refuses to work, no matter what I try.
    I guess I would have to send the device back for warranty repair, which is very inconvenient for me. I bought a very long USB cable with repeater instead, it solved my problem (at least temporarily). Case closed.

    Thank you for your support.

    With best regards

  • Greetings,

    For you to send anything to our facilities, you must have an RMA ticket with us. Please let us know that you want something sent by going to Support page -> Support requests and requesting for an RMA ticket.

    Takao Yamada

Add comment

   Want to comment? Please login or create a new PEMicro account.

© 2018 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement