Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

Please accept the use of cookies on our site

At PEmicro we use web browser cookies in order to provide you with an enhanced experience and in order to be able to do things like shopping cart processing and identify you when you login to our website.

Click here to accept

search inside this forum
search inside all forums
Multilink Universal Not Connecting to HC12
Matt D. Apr 1, 2016 at 03:04 PM (15:04 hours)
Staff: Takao Y.

  • I have several Multilink Rev A and B models that work perfectly with all our HC12 hardware when connecting to ICD12Z or PROG12Z. But, I just purchased a brand new Rev C Multilink and it fails to connect.

    I have updated the firmware in the Multilink to 9.59. I have verified that I have 5V on the connector and that the RESET line toggles while attempting to contact the hardware. But, the BKGD line is just stuck at 5V and doesn't toggle. This line is pulled up to 5V through a 10K pull-up on my board, and works fine with the Rev B and Rev A Multilink units I have. I have both blue and orange LEDs on the Multilink.

    The Rev C interface is successfully detected by both programs, and I have tried setting the BDM communication speed to Autodetect speed as well as several manual speed settings. I always get the error "Could not find appropriate io_delay_cnt".

    Does anyone have any other troubleshooting steps I could follow?

    Thanks in advance.


  • Greetings,

    I want you to download our resource CD and make sure you are using our latest firmware updater software. Many customers who have used our multilink universals in the past keep using the same utility from the past without downloading the new resource CD that came with the new multilink. The latest version is necessarily:

    Takao Yamada

    • Hi Takao,
      Thanks for your response. I downloaded that updater utility earlier today and that's what installed V9.59 in my Multilink. I noticed on the version page that 9.60 is the current version, but all the updater utilities I've seen have installed V9.59.

  • Greetings,

    Version 9.59 is the latest version we have.

    A few questions:

    1) Are you using any custom ribbon cables, adapters, external watchdog, or other unique hardware between the multilink and the chip?

    2) Do you know if the chip is secured? Confirm using unsecure 12 utility that you have a unsecured chip before trying to communicate:

    3) Have you tried removing the pull-up resistor on BKGD to see if it behaves differently?

    Takao Yamada

    • 1) I soldered 4 wires onto the pins of the BDM connector that go to a 4-pin JST connector to my PCB. I have confirmed the pins are correct and have ohmed out the wires.

      2) The chip is not secured.

      3) I removed the 10K pullup and the unit still doesn't connect. It fails the speed test still.


  • Greetings,

    When you used the unsecure 12 utility, was it able to connect to the chip? Because if it was able to determine the chip is not secured, that is a step forward. But if the utility cannot talk to the chip using the unsecure 12 utility, then we are still stuck.

    Could you do one more test, which is to replace the ribbon cable. Sometimes the ribbon cable is the weakest link that breaks the communication.

    Takao Yamada

  • Greetings,

    Any update on this?

    Takao Yamada

    • Hi Takao,
      I am not using a ribbon cable, but rather just 4 wires that I soldered directly to the BDM pins of the Multilink. I have confirmed that this wiring harness is good by a continuity check on each wire, and I've also taken measurements on each end of the harness to ensure the readings are the same.

  • Greetings,

    How about the unsecure 12 utility? Did you use it and was it able to connect to your multilink and determine the chip was unsecured? This is very important for me to know so please try the utility.

    Takao Yamada

    • No, Unsecure12 is unable to connect to the chip also.

  • Greetings,

    So you definitely have a hardware problem. Is this problem happening in all of your HC12 projects, or this is only happening on a specific chip you are using?

    It is possible you have a defective unit. It does not sound like you have ever gotten it to work at all.

    What we can do is if you are located in the USA then I can assign you an RMA ticket and you can send your multilink back to us. It would be ideal if you could also send a HC12 target you have confirmed as not working and with the ribbon cable you are using. I would like to replicate the issue so that we can help diagnose the problem. If this is a possibility, let me know.

    Takao Yamada

  • Greetings,

    How would you like to proceed? Do you want an RMA for your hardware?

    Takao Yamada

  • Yes, please. I will try to send in the unit next week and see if I can provide a PCB so you can troubleshoot the Multilink.

Add comment

   Want to comment? Please login or create a new PEMicro account.

© 2018 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement