Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

Please accept the use of cookies on our site

At PEmicro we use web browser cookies in order to provide you with an enhanced experience and in order to be able to do things like shopping cart processing and identify you when you login to our website.

Click here to accept

search inside this forum
search inside all forums
Codewarrior/Multilink Universal/MPC5674F Issue
William O. Jan 29, 2016 at 12:19 PM (12:19 hours)
Staff: Takao Y.

  • Good morning,

    We are having an issue getting the Multilink Universal to work with the following setup:

    Window 8
    Codewarrior 10.6 Build 140329
    Multilink Universal with Driver version
    iSYSTEM development board with MPC5674F

    The connection between the Multilink Universal and iSystems board is via JTAG/Once and the iSYSTEM board is jumpered to use this interface.

    Things appear to hook up OK but when I go to debug a RAM based project RAM does not appear to get written and reads back as all 0's. In addition when I look at the Registers they all appear to be 0's with the exception of the PC which is set to the value of __start.

    We have tried this with a different Multilink Universal as well as a different iSYSTEM board, same result.

    We also tried this with a USB Multilink and everything works properly, can read/write RAM and can read/write registers and things appear to debug properly.

    The indication from this is there is an issue with the Multilink Universal and this setup.

    Help would be greatly appreciated as I am a bit stumped.

    Thank you!

    Bill Ockert


  • Two more details...

    The Multilink Universal is Rev C.

    I updated the Multilink Driver to rev same result

  • Greetings,

    The multilink universal will work well with Codewarrior version 10.6.4. The reason is that the older multilinks and newer multilinks have different firmwares, and the older Codewarrior versions did not have the firmware for the new ones. Try updating and see if that makes a difference.

    Did you download the CD that came with the universal multilinks? You need to make sure you are using the latest firmware. Here is a link and use the firmware updater utility:

    Takao Yamada

  • Good afternoon Takao,

    Thank you for the reply.

    I had originally used the CD that came with the multilink however had updated to V12. Just to be safe I downloaded an installed the drivers / firmware in the link you provided. This appeared to be what I was already running but just to be safe I reinstalled.

    An oddity... when I use the multilink firmware updater and click Update Firmware the selected firmware ubmlfsufjtagens.940 appears to get uploaded. However if I click on Update Firmware again it still claims the firmware is out of date and uploads it again.

    After doing this I tried CodeWarrior again and got the same result. Things look like they are working but am unable to load RAM or change value of registers.

    Outside of the oddity detailed above I believe I am running the latest firmware and drivers.

    Any other ideas?

    Thank you!

    Bill Ockert

  • Greetings,

    The firmware updater will always attempt to update the firmware, even if you are using the same version. So once you have it loaded, you are set.

    Again, you should try to update Codewarrior to version 10.6.4 so that you have the latest changes.

    Another thing to try is lowering the debug shift speed/frequency found in debug configurations.

    Have you tried a brand new project within Codewarrior and without changing the code or settings just try to debug? This should work out of the box. If you can get this working, then we just need to find out what changes you made that caused the problem.

    Takao Yamada

  • Takao,

    The project I am attempting to debug is a stock new project with the simple forever loop in main. Nothing was changed.

    I just changed the debug shift speed to .5MHz and everything started working
    so that was the issue. We may need to look at upgrading to the FX version as our eventual program will be quite large.

    Thank you for your help!!


  • Greetings,

    Yay! I am glad I was helpful. Please note, that the FX is going to be much faster unit, so you may need to further lower the debug shift speed. This is the communication speed between the multilink and the target unit.

    Takao Yamada

Add comment

   Want to comment? Please login or create a new PEMicro account.

© 2018 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement