Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

Please accept the use of cookies on our site

At PEmicro we use web browser cookies in order to provide you with an enhanced experience and in order to be able to do things like shopping cart processing and identify you when you login to our website.

Click here to accept

search inside this forum
search inside all forums
CyclonePro, PROG works, Image Creation Utility Does not
Christopher R. Oct 27, 2015 at 02:17 PM (14:17 hours)
Staff: Takao Y.

  • Hello,

    My name is Keith and my issue is using the Cyclone Pro and Image Creation Utility(V4.01). My processor target is a Freescale MC9S12A64.

    I open the utility, launch the script wizard, select Freescale_9S12A64_1x16x32k_64k_Linear_16k_page.12p, and then select my object file - the .s19 file created from CodeWarrior for S12 V5.9

    The wizard creates the script:
    CM (path)\Freescale_9S12A64_1x16x32k_64k_Linear_16k_page.12p
    SS (path)\Project.s19
    EN ; Erase if not blank
    PM ; Program Module
    VC ; Verify Checksum

    I then click the store image to cyclone button it makes it to PM:Program Module and fails saying: Checking range of S records. Invalid Address detected. Invalid addresses in srecord block from $0000c000 TO $0000c01f.

    I know the srec file I'm trying to program is good. The PE USB Multilink and Cyclone Pro using HIWAVE programs the image fine. PROG for S12(X) also works fine with this image. I need the standalone feature for a production environment though and need this to work.

    For an experiment I checked 'ignore address range check' and hit store image to cyclone again. It then makes it all the way through to VC command where it fails stating: Generating Object File CRC-16 to device ranges ... Error - no valid data in the range of the module.

    For a further experiment I removed the VC from the script list and clicked store to cyclone. It stores it with that but when programming from the Cyclone's interface my target doesn't receive the firmware correctly (doesn't function at all).

    Anyone have any insights as to what the problem may be?



  • Greetings,

    If you got the S19 file from Codewarrior, then I am in disbelief that it worked with PROG for S12(X) without having to do any conversion.

    The normal procedure for using P&E tools is converting your S19 file into PHY file format using our LOG2PHY utility:

    Our tools only work in physical format and the S19 file is in logical format. You must convert the file and then PROG and standalone will work just fine. Try converting your file and let us know if it worked.

    Another solution is grabbing the GLO (global) file from Codewarrior in the same workspace. This is already converted into the physical format.

    Takao Yamada

  • Hello Takao,

    Codewarrior produces a .phy file as well as the .s19 mentioned. When using PROG I used the .phy file.

    I mention .s19 in my issue above because the Image Creation Utility filters out the .phy file and won't let me select it. After launching the script wizard and selecting the algorithm - the window that asks for the Object File to Load does not show a .phy file (I have verified it is in the folder I am looking in). I have chosen every option in the drop down box for File Type but the .phy file doesn't show up. The .s19 srecord does show up however.

  • Greetings,

    When the prompt shows up to select your object file, type in *.*

    This changes the filter option to show all files. Here you can select your PHY file.

    I have been bugging the cyclone team to fix this problem for months and they have not fixed it yet. I won't give up!

    Takao Yamada

  • That worked. Thanks!

Add comment

   Want to comment? Please login or create a new PEMicro account.

© 2019 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement