Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service


Please accept the use of cookies on our site

At PEmicro we use web browser cookies in order to provide you with an enhanced experience and in order to be able to do things like shopping cart processing and identify you when you login to our website.

Click here to accept



search inside this forum
search inside all forums
P&E USB Driver Licensing Issue
. Sep 8, 2015 at 07:47 AM (07:47 hours)
Staff: Johnny N.

  • Everything has been working previously, then;

    While in the Debugger mode an information box pops us displaying,
    "There is a P&E USB Driver Licensing issue on your machine. I was then directed to download and install the latest driver from;
    [pemicro.com/downloads/download_file.cfm?download_id=53]"

    I have recently uninstalled and reinstalled all Kinetics, the Win Drivers, PEDrivers_Install.... They are all up to date and working!!!

    I have a Windows 10 operating system, could that be a problem?

    But this window continues to pop up, I saw on a forum there was a patch or something, does anybody know???

    Thanks,
    Clinton E




    Comments

  • Let's work to resolve the issue in the support ticket you opened in our system. Once we have a resolution we can post it here for the public.

    Best,

    Kevin

  • Hello, 

    I have the same problem on Win7.

    Had a Codewarrior 6.3 running, then installed PROG12Z and PROGHCS08 Software in order to program freescale microcontrollers in production without using Codewarrior.

    Even re-installed Codewarrior, still got the issue..

    Best,
    Florian

  • Hello,

    I have same problem too.

    I am using CW 10.4 on Win 10 64bit and in debug session opens same popup.
    Tryied reinstall drivers, cw nothing changed.

    Best,

    Jirka

  • There is a known issue with P&E Drivers and Windows 10. We are working to resolve the issue as soon as possible. 

    At the latest, there will be a new version of P&E Drivers that supports Windows 10 by Friday September 25th.

    Best,

    Kevin

    • Thanks for great news

      Best,

      Jirka

  • Please resolve it A.S.A.P  !!!!!!!!!!
    I don’t want to reinstall back to windows 7
    It will be great to inform us when it will be resolved.
    Thanks in advance
    Shaul

  • Good to hear there is a Win10 driver on the way, as I have just encountered this problem too.  It has been working fine running Win 10 64 bit until this morning.  There was a security update installed (KB3081455) which I have uninstalled, but still get the same message - so I'm not sure if it's related.

  • Hi All,

    Attached is a patch for Windows 10 and P&E Drivers.

    http://www.pemicro.com/downloads/download_file.cfm?download_id=460

    Please remove all P&E hardware from your machine and close all P&E/Freescale software and install the above patch. Reconnect your devices/restart your programs and the issue should be resolved.

    Best,

    Kevin

    • Hello Kevin;
      On first run it works!!
      Let’s hope that it solves the problem
      Thanks’
      Shaul

  • Hey,
    Thank you so much!!
    All working great!

    Cheers,
    Clinton E

  • Windows 10 is now supported in the main P&E installer:

    http://www.pemicro.com/downloads/download_file.cfm?download_id=301

    • Same licensing issue has re-appeared, after fixing it last year. (I think there has been an automatic windows 10 maintenance.)
      Now when I run the above file (id=301) i get "Cannot run an x86 build of this utility on a x64 platform".

      Also the link to download_id=460 is non existent.
      regards
      Steven

      • P.S. To the above. I've also tried to run Drivers_v_install.exe in compatibility mode and get the same "Cannot run an x86 build of this utility on a x64 platform".

  • Steven,

    That is the incorrect link. It must have changed since the post.

    Please try the following installer: http://www.pemicro.com/downloads/download_file.cfm?download_id=53

    I am not sure why the message has reappeared for you.

    Best,

    Kevin

  • Mark,
    I've installed that driver version - same result "There is a P&E USB Driver Licensing issue on your machine."

    Everyting was working a couple of weeks ago. I've tried uninstalling and deleting the jungo drivers before installing. same result.
    Thanks
    Steven

    • I've tried the patch in FAQ 211, but that results in the "Error while writing to E000..E200. Information: Access denied (target running)" when I run the debugger. I'm using CW6.3 and the MCU is MC9S08QG8.

    • Sorry Kevin,
      I don't know where I got mark from.
      Steven

  • Steven,

    I believe the reason you are getting the licensing issue is that you are using an older version of code warrior.

    The patch is the best way to resolve this issue. I would be happy to remote into your machine and help you get the patch up and running.

    Best,

    Kevin

    • Thanks Kevin,

    • Thanks Kevin,

    • Kevin,
      It works! What I did wrong before was that I renamned the PE folder, instead of making a copy, before adding the patches.

      Thanks again
      Steven

  • I'm in Australia and am at work until 5pm our time. When I get home I will try reinstalling CW_MCUV6_3_SE downloaded  8/7/2016 and patch it with VW63_patch_S08.RS08,CFV1.zip according to the instructions therin. I'll let you know how I get on. 

    Steven

  • Hey,

    I'm seeing a similar problem showing that the access is denied and I believe I am using up to date installer and drivers. Is there something else that I need to install?

    Thanks for any help!

    • Zuhaer,

      Can you send a screenshot of the error message and the specifications of your PC to technical-info@pemicro.com?

      Regards,
      Johnny

Add comment


   Want to comment? Please login or create a new PEMicro account.







© 2018 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement