Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

Please accept the use of cookies on our site

At PEmicro we use web browser cookies in order to provide you with an enhanced experience and in order to be able to do things like shopping cart processing and identify you when you login to our website.

Click here to accept

search inside this forum
search inside all forums
newbie with MultLink prog custom KL27Z128
Neil H. Aug 31, 2015 at 02:02 PM (14:02 hours)
Staff: Takao Y.

  • Hi, I've just purchased a PE Multilink - thanks so much for the very fast order - this was a recommendation from FreeScale
    I'm using KDS300, and had earlier versions of this custom board running with JLink.
    I've used PE with FRDM-KL27Z to test the basic blinkey program
    However I'm having trouble connecting to my custom KL27Z128 target.
    I've looked over all the FAQs to get an idea of how to start and install the PE Multilink.
    I initally downloaded the multilinkRevC_universal_install.exe and installed it.
    Then this morning plugged in the Multilink.
    Started KDS3 with my program - it attempted install but upgraded.
    When instructed restarted emulator and then also KDS to verify upgrade.
    I check the Multilink Blue and Yellow power leds are ON
    It says "An error occured while connecting to the interface hardware.."

    I try the "P&E Kinetis Recovery Utility V0.02" and it says
    "Comms via SWD"
    Cable Version is 933
    Success. Processor halted
    I exit "recovery utilit" leaving MultiLink conected, and power on.
    Switch to KDS and try debug using MultiLink - same result.
    Any suggestions - or FAQ on using MultiLink with KDS300 and Kinetis


  • Greetings,

    You indicated that you have used our tools for the FRDM board (assuming the OpenSDA interface). Have you tried maybe using the multilink on the FRDM board? You may need to install JTAG or SWD header onto the board but this is a good way to try to see if your multilink is working properly and your settings are good.

    Your Kinetis recovery utility results do indicate that the P&E interface did have success talking to the chip. So my guess is your problem is some settings inside KDS. KDS 3.0 has everything you need so you do not need to download or use any other utility. I would advise creating a new default project and try debugging without any changes to settings or code.

    Takao Yamada

  • Thanks for fast response, I created a new project KL27128-basicA with gcc, compiled it OK.
    Then through debug icon, debug configuration - didn't touch anything
    Then pressed Debug button.
    had window
    "Launching KL27Z128-basicA_Debug_PNE
    PE Connection Assistant windowlet came up,
    same "An error occured while connecting to the interface hardware..."

    Is there a log listing of what that the error is.?

    Aborted the PE Connection

    Tried again with P&E Kinetis Recovery - Sucess.
    Exit Recovery
    Started KDS3
    Started Debug-
    P&E connection Assistant windowlet - "An Error occurred .."


  • Greetings,

    Could you install the following multilink universal utility package and use the "firmware updater" utility. Use this and see if you can update your multilink to the latest firmware for Kinetis. Even if you have used this utility before, get this latest version. This is a sure way of knowing if your multilink is in working condition:

    If the firmware updater fails, then there probably a driver issue.

    Make sure you only have one software running. Some utilities keep the port open and does not allow the other software to be able to open and close that port.

    Takao Yamada

  • Ok - so I download the package (add on 150831 to back)- make sure the MultiLink is not plugged in, execute 
    uninstall from c:\n\bin\PEMicro\multilink_univcersal
    install to c:\PEMicro\multilink...
    Run Universal Multilink Formware Update
    Firmware file is usbmlfsufarmens.0940

    Interface detected old firmware, updating

    please remove hardware

    rebooted, started up
    (No way of detecting/reading what version programmed)

    Started KDS3
    ran debug KL27Z128-basicA_Debug_PNE
    P&E connection Ass "An error occured while connecting..."
    tried again
    TUrned off target, removed USB, plugged back in, powered target
    same result.

  • Greetings,

    At least the multilink is working. Just a few more questions:

    1) Are you using any custom ribbon cables, adapters, or other unique hardware between the P&E interface and the chip? Or are you using just the multilink and the ribbon cable that it came with? Do you have a reset driver, external watchdog, or anything that may impede communication?

    2) Have you gotten your custom board working in the past? Do you have any other targets that you could try connecting to? This would help rule out KDS and the multilink and drivers as a problem.

    I may ask you to go to Support page -> Support requests to create a ticket and we will try running some debug on KDS to help us out. But not appropriate to detail in a public forum.

  • Hello, very much appreciate the ideas and quick response
    1) No custom ribbon cables, adapters - I would add a picture of the setup and circuit diagram if I could
    2) The custom board has worked on a previous revision, but this is a new revision
    The Reset, NMI pin, SWD_DIO pin are pulled up through 10K, and SWD_CLKI pulled to 0V through 10K. The Reset has 0.1uF to gnd.

    I do appreciate the quick help and insights and I was hoping it was something easy that I had missed.
    I do have two older boards that worked with a J-Link, one a K20DX and the other a KL26Z128.
    I haven't tried them with the KDS300 update as I wanted to understand if there was an issue with it or the emulators.
    Seems to me I should
    1) Try with a KDS2 installation the KL26Z128 - report back
    2) possibly uninstall the KDS300 and reinstall KDS300/SDK1.1 again - and try above as well with KL26Z128 - report back
    3) request the customer support ticket

    Part of the issue has been that too much has changed at one time to really zoom in on where the issue is - software tools KDS or JLink fw/hw or my new hardware
    a) KDS3 had an update that caused problems
    b) Freescale released a new update KSDK1.2 that forced older ProcessorExpert components to become invalid - taking away test framework components on newer processors
    c) For me a new revision of hardware with KL26Z that seemed to be bricked by the J-LINK and continually reset as it had no program.
    So I built my last proto board with a KL27Z (which requires KSDK1.2) which has emulator problems. However the KL27Z has a KBOOT so the processor appears operational - meaning that the processor hardware is actually fully functional.

  • Greetings,

    It possibly could be a easy thing that you missed but I cannot see your setup so I have to ask a lot of questions.

    You could try recovering your bricked unit using P&E's utility and P&E's multilink:

    If you get a chance, try the K20DX board with the multilink. I just want to make sure the multilink can work in the KDS environment you are using. And we know the K20DX board is in working condition. So this test would rule out the multilink, its firmware, and drivers.

    KDS 2.0 may have issues if you got the latest multilink from us. KDS 3.0 has the support for our latest hardware.

    Takao Yamada

  • Ok thanks for the info not to use Multilink latest and KDS2
    I created a basic KDS300 K20DX256 project,
    connected the Multilink and powered my board - blue and yellow leds ON
    On KDS300 Configure then Debug launching K20DX256_Debug_PNE

    same issue - "An error occured

    I also have a FDM-KL25Z with JTAG 0.05" soldered in so trying that.
    So to be clear I connected the supplied cable to Multilink bottom right PortG (2x5 on 0.05" centers)
    On Debug its launching the internall specified GDB - I've installed the Kinetis GDB seperately.

    For KDS300 created a
    FRDM-KL25zA project with only PE, and on launch It also had same Issue
    Frdm-KL25zBb project with only KSDK1.2 and it had issues "An error occure

  • Hello,
    I've uninstalled all of Freescale KDS everything, and also PEmicro, Segger drivers
    Then installed
    Then I've created a new workspace.
    I created a project based on the FRDM-KL25Z,
    Compiled and started a PNE_DEBUG - and it work, it stepped into main and halted. IT WORKED.

    I then created a project MK20DX256VLH7-aa, with ProcessorExpert (SDK1.2 not supported), and selected a target processor of MK20DX256xxx7
    Through PE, changed the default processor MK20DX256VLH7, compiled the project.
    Started Debug-Configure - configured MK20DX256VLH7-aa_Debug_PNE
    The target custom board is a revision that was debugged by a JLINK and known to work.
    Then on the debugger pressed Debug - it launched and was able to step through the programs. IT WORKED.
    I then created a project KL27128VFT4, with no SDK1.2 (and therefore no Processor Expert support, an SDK1.2 "Feature")
    I compiled and then configured the KL128VFT4-dd_Debug_PNE with Mass Erase, and ensured Use SWD Protocol
    The target debug board is a custom board with KL27128VFT4 that had a basic Blinkey running - programmed once by a JLINK, but was unreliable. The JLINK had problems as identified above.
    Pressed Apply, then Debug
    It had "An error occured...." Retry About - I retried a number of times
    I ran the "P&E Kinetis Recovery Utility v0.02"
    On 2nd power cycle it said "Success. Processor Halted"
    I exited Recovery utility, and tried Debug- KL128VFT4-dd_Debug_PNE

    It had "An error occured...." Retry About - I retried a number of times

    I then created a project for a KL27Z128-basicCc, with SDK1.2 and ProcessorExpert Enabled
    I changed the processor to MKL27Z128VFT4,
    I Compiled the project,
    configured the debug KL27z128-basicCC_Debug_PNE
    and set "Mass erase on connect"
    The target debug board is the custom board with KL27128VFT4
    On debug, it started and then "An error occured..." Retry About - I retried a number of times

    I ran the "P&E Kinetis Recovery Utility v0.02"
    On 1st attempt it said "Success. Processor Halted"
    I exited Recovery utility, and tried Debug- KL27z128-basicCC_Debug_PNE
    it started and then "An error occured..." Retry About - I retried a number of times

    I have one other MKL26Z based board I can try tomorrow to see if I can get that to work.

  • Greetings,

    Great! I am not sure what you did differently this time but it seems now only the KL27 project is giving you problems. I am glad to know that the other project do work so that indicates your multilink and IDE and drivers are all working well.

    What I am going to do is locate a KL27 device and try to replicate the problem on my end.

    Takao Yamada

  • Hi Takao
    I agree better to start with known. I have a FRDM-KL27z and dug through my filing system to find a 0.05" header. So just looking at the FRDM-KL27z schematic, and I think it would work to use this as a starting point to verifying the Multilink and Software ? Do you agree?

  • Greetings,

    Yes, that is exactly what I was going to do as well. I did locate my FRDM-KL27Z but it was dead. Could not even get it working using the recovery utility we have. So I may need to purchase one from Freescale, so I will be delayed in getting a result on my end.

    Takao Yamada

  • Hello Takao
    Oh well interesting I'm not the only person with hardware issues. The basis of all good software is solid hardware:)
    Yes - so what I've done with my Win8.1 environment is scrubbed it of all older related tools, and only installed KDS300, KSDK1.2, and PeMicro Multilink - and installed them in the default folders. Before I had taken the option to put them in a separate c:\n\bin\ folder to keep them tidy.

    On the FRDM-KL27Z I soldered on J11 and then looking at the schematic to disconnect the OpenSDA I unplugged J6, J7
    Then on trying the empty/basic program - it does seem to have programmed it. Whew another step in verifying stability.
    The processor variant pins/memsize is different between the FRDM-KL27Z and the MKL27Z128VFT4 I'm using.
    I'm now trying to audit my new PCB revision for what may be causing a discrepancy. I did switch from the KL26Z128VTF4 to KL27Z, and I did change the function of some pins, but I can't see how this affects it.

    I took an option to make the NMI/PortA4 an output, though I still have it pulled up to 3.3V through a 1M. So I'm auditing the changes and will do more tests.

  • Many thanks for the support.
    For the KL27Z I was able to access it with KBOOT/USB and with
    get-property 17  KL27Z256 Flash Security State = SECURE

    I built all the prototypes I had which used QFN 0.5mm - so not possible to change the processor with any confidence, so I decided to reorder more boards - but make some changes on the PCB and used a KL27Z / LQFP 0.5mm which I hope is easier to have confidence in.
    I also have another board arrived with the big brother new MK26FN2M processor that I'm building so will be trying to program that in the next couple of days.

  • Greetings,

    Any update on this?

    Takao Yamada

  • Yes thankyou. I'm using the multilink with the MK26F no problem. Had a few problems in the board so very happy the multilink is playing. 
    I initially also tested it with a FRDM-K64F board - both a software module and also the multilink.
    I've made sure I don't update the KDS300 as the update is still broken with a segger component - however its not clear when deselecting the Segger component what impacts it has so I've chosen to not take any update. has created a standalone way to debug once the basic board-support-package has been defined.
    many thanks again.

Add comment

   Want to comment? Please login or create a new PEMicro account.

© 2018 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement