Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

Please accept the use of cookies on our site

At PEmicro we use web browser cookies in order to provide you with an enhanced experience and in order to be able to do things like shopping cart processing and identify you when you login to our website.

Click here to accept

search inside this forum
search inside all forums
Creating SAP image file for Cyclone Max
Gareth F. Jul 12, 2015 at 09:14 PM (21:14 hours)
Staff: Takao Y.

  • I'm trying to create the SAP image file for a Cyclone Max so I can program the internal memory of an MPC5675K microprocessor.

    The code I'm using to create the SAP image is a binary file that is provided for us by our customer. When I try to create the SAP image file I get the follow error message:

    Preparing data ... Address $ Error (C:\Aker\AkerFirmware-Issue01.bin) : File not found -or- Unknown file type
    .Error duriing data preparation.
    ERROR 18 during script!

    I've also tried using the MOT file and got the same error.

    I'm using Cyclone Max Image Creation Utility v5.21.00.00.

    Any help that you can provide would be most appreciated.


    Gareth Franklin


  • Greetings,

    Where did you get this bin or MOT file? Did the compiler generate a ELF file? The MOT should work just fine. The error you are getting means the utility cannot recognize the contents inside of the file.

    Check your compiler and make sure the file generated has contents inside. Check for any compilation errors.

    Takao Yamada

  • Hello,

    The bin files are provide to us by our customer. The MOT file came from a test program that I wrote and compiled just to verify the hardware. The ELF file has been generated but I've not tried to create the SAP image with it.

    There are no compilation errors and the generated files have contents inside.

    Neither the bin files from our customer or the MOT file I generated would work when I tried to generate the SAP file. I got the error code 18 message.

    Since then I've managed to convert the bin files to an s record file using a 3rd party program so now I can create the SAP image. However, when I try to flash the processor I get error message $0000000A on the Cyclone Max screen.



  • Greetings,

    I want you to do 2 things:

    1) Update your cyclone max software and firmware to the latest version:

    2) Use the PROG for PPCNEXUS software included inside the cyclone max software package and do a step-by-step flash programming procedure. This can greatly help you in debugging the roadblocks you are running into. Only when things work fine in PROGPPCNEXUS then you should move onto automating it within the image creation utility.

    Could you detail which algorithm you are using?

    Takao Yamada

  • Greetings,

    Any update on this?

    Takao Yamada

  • The well mentioned about the SAP Image file in this post. I hope that we will get this kind of stuff in the future also.

Add comment

   Want to comment? Please login or create a new PEMicro account.

© 2019 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement