Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

Please accept the use of cookies on our site

At PEmicro we use web browser cookies in order to provide you with an enhanced experience and in order to be able to do things like shopping cart processing and identify you when you login to our website.

Click here to accept

search inside this forum
search inside all forums
FX on S12G
Alan B. Jul 6, 2015 at 01:11 PM (13:11 hours)
Staff: Takao Y.

  • Hi

    1. The FX says it cant connect to hardware. I have ran Test program and it said some files were missing. I downloaded these from ur site ans still same problem.

    I ran test again and it says Error Free. The older Multilink connects fine.

    2. I want to load some of my program on a separate Flash Page. Where can I set which page the program will load to?

    It says that a full erase is carried out on programming so even if 2. above is sorted what do I do.

    On the S08 It erase chip and then re-writes selected memory. Only on page 0.

    Again same problem. I am sure there is a simple solution but I just cant find it. Can Anyone help.

    Its an old assembler program but works fine just needs some more room and it will take so long to re-write in C



  • Greetings,

    1) Did you make sure to download and install the resource CD that the multilink came with? You can download it here if you lost the CD:

    You need to use the firmware update utility and make sure you have the latest version of the firmware.

    2) The page of where the data is programmed is dependent on the logical address. You should look into your project's linker file to see where the data is being programmed. If you are using assembly, then you should be using "ORG" command to move your data to whatever address. For example,

    ORG $3000

    My code:

    ORG $4000

    My other code:

    Then, you can use the LOG2PHY utility to convert the data from logical format to physical format. You can see the pages that it will convert to within this utility:

    Takao Yamada

  • Hi
    Downloaded CD and ran. No improvement.

    Going back to old Multilink that works fine. Yes I can and do use ORG. BUT
    how do I load code on to an extended page. How do I set the page pointer before code is loaded.

    Can I load a value into it when I download the code. I tried and it does not seem to work.

    I want mane program to run and be able to "call" a subprogram. on an extended page. I cant get my mind around how to do this.

  • Greetings,

    1) You may need to upgrade your PROG or ICD software if you are using the rev B of the multilink universal FX. Please use this table to find out what software versions are supported:

    If your software is too old, then you need to purchase an upgrade your software. Please go to Support Page-> Support Requests and tell us the version of your software. We can work with you in getting upgraded software.

    2) What IDE and assembler are you using? Are you using P&E's assembler? If so, there is a Pseudo-Ops called "PCALL n" where you can use this to generate a call to a logical paged address "n".

    Takao Yamada

  • Greetings,

    Any update on this?

    Takao Yamada

  • Hi
    I have moved, for now, with Multilink.
    Using code Warrior 6.3 on s08 and 5.1 on S12.

    All works well. My problems are:
    1. How do I load program modules on paged Flash. On the base page ALL previous program data is erased on programming new data.

    2. So even if I xan load progeam modules on paged Flash will it be erased when loading the main program. The call works fine except I cant see how to get modules on multi pages.

    I have been using the S12 to reduce program size to fit in with base Flash but I need more memory.
    The memory would not be thr if u cant acces it so what am I doing wrong.

    Should I move from CW is the an assembler that allows u to set page or does CW allow this. I have spent many hours looking but failed. Pls pls help.


  • Greetings,

    If I understand you correctly, you have 2 programs and what you are seeing is that trying to program one erases the other program. Is this correct?

    The problem with Codewarrior is that it will always run the same set of commands to program your chip. It will erase, program, and verify every time. If you indeed have 2 programs and trying to program them both onto the chip, you need more advanced tools. Let me know if this is the case and I can point you in the right direction.

    Codewarrior is still the best solution for assembling and debugging your chip. If you check the linker file, you can see where the data is being programmed. You can move data around by changing the linker file.

    Takao Yamada

  • Greetings,

    Any update on this? Still having troubles with Codewarrior?

    Takao Yamada

Add comment

   Want to comment? Please login or create a new PEMicro account.

© 2018 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement