Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

Please accept the use of cookies on our site

At PEmicro we use web browser cookies in order to provide you with an enhanced experience and in order to be able to do things like shopping cart processing and identify you when you login to our website.

Click here to accept

search inside this forum
search inside all forums
USB Multilink Universal debugger breaks after starting GDB server from command prompt
matt j. Jun 23, 2015 at 03:26 PM (15:26 hours)
Staff: Gerardo R.

  • Hello,

    I am having an issue with the Multilink Universal debugger seeming to break after starting the gdb server from the command prompt. I have a PEMicro Multilink Universal debugger connected to the computer and a Kinetis uPC device.
    When using the pegdbserver_console.exe program found under KDS_2.0.0/eclipse/plugins/com.pemicro.debug.gdbjtag.pne_/win32 folder from the command prompt, the Server will not be able to connect to the Multilink device and I receive the message "cannot enter background mode".

    This problem has occurred on both a Rev C Multilink and a Rev B Multilink. Neither work any longer, even when used on an entirely different computer.

    Kinetis Design Studio is still able to detect the Multilink Universal debuggers and the lights on the debugger seem to continue to work correctly, but the devices will not debug or perform updates on the Kinetis device.

    Attempted Solutions
    - (x) Rebooted computer and cycled power on device to be updated
    - (x) Switched USB port
    - (x) Reloaded firmware on the Multilink device
    - (x) Use Multilink device on other computer that uses a different, working, Multilink device
          * The device still fails in the same way
    - (^) Use a different Multilink device on my computer
          * The new Multilink device works fine on my computer
    - (?) Reinstalled PEMicro drivers (have not tried this, but it did not seem relevant based on other attempted solutions)

    Possible Causes
    I have a batch script that runs the pegdbserver. Mistakenly, I terminate the command prompt right after it is done sending the command.

    My command is:
       gdb_server.bat /K
    When it should be:
       gdb_server.bat /C
    After this occurs, I run the script for the client (which fails because it does not see a server).

    This is the only thing I can see that could have caused a problem.   

    Other Comments
    I have been able to successfully update Kinetis devices using a method similar to the above previously. However, now I have 2 PEMicro Multilink Universal debuggers that do not work whatsoever and I am not able to test other methods of using these functions from the command prompt out of fear of rendering other devices useless.

    Is there any way to recover these 2 devices?
    Also, is there any advice on how to properly run the server and client programs from the command prompt/scripts?

    Thank you,


    P.S. I included the scripts I use below

    bootloader_programmer\pegdbserver_console -startserver -device=K22FN1M0M12

    bootloader_programmer\gdb_client\arm-none-eabi-gdb -x bootloader_programmer\scripts\gdb_client.bat

    # connect to the pemicro gdb server
    target remote localhost:7224

    # reset the microcontroller
    monitor _reset

    # load the elf file
    load "//server1/uC/bootloader/freedom_bootloader_K1.3.1.elf"



    • *sorry, I had the command prompt options switched around...

      Under "Possible Causes", it should read:

      My command is:
         gdb_server.bat /C
      When it should be:
         gdb_server.bat /K

  • To start off, please install the Multilink Universal software and use the firmware update utility to reprogram the device. If that doesn't restore functionality than we can try further diagnostic steps.

Add comment

   Want to comment? Please login or create a new PEMicro account.

© 2018 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement