Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

Please accept the use of cookies on our site

At PEmicro we use web browser cookies in order to provide you with an enhanced experience and in order to be able to do things like shopping cart processing and identify you when you login to our website.

Click here to accept

search inside this forum
search inside all forums
KDS 3.0.0 and Cyclone MAX problems
Nicolas P. Jun 9, 2015 at 10:09 AM (10:09 hours)
Staff: Takao Y.

  • Hi,

    I try to use a Cyclone MAX with KDS 3.0.0.
    I have installed last drivers for Cyclone MAX.
    I have installed KDS 3.0.0.

    Cyclone MAX is connected through Ethernet Port.
    Cyclone MAX is connected to a FRDM-K22F board. The converter cable from Cyclone MAX to FRDM-K22F board is self made (waiting for the P&E adapter cable).

    I have removed J10 and J13 and FRDM-K22F board.

    I have created a "hello world" application.

    I have setup a debug configuration in the "GDB PEMicro Interface Debugging" section.
    KDS recognises Cyclone MAX.
    I have setup the processor type to K22FN512M12.
    I have checked SWD box.

    When I run the debug session, I get an error dialog box :
    Title : P&E Connection Assistant
    Content : An error occured while connecting to the interface hardware or target specified in the Launch Configuration Dialog. For this launch, you may retry/re-specify the connection with the following parameters:

    Clicking "Retry" shows the same dialog box.
    Clicking "Abort" does the same the the first time and displays another error dialog box the second time :
    Title : Problem Occured
    Content : 'Start GDB Server Job' has encountered a problem. An internal error occured during: "Start GDB Server Job".

    An internal error occurred during: "Start GDB Server Job".
    RequestMonitor: Sequence "", result for executing step #0 = Status ERROR: org.eclipse.cdt.dsf code=10005 Request for monitor: 'RequestMonitor (com.pemicro.debug.gdbjtag.pne.Backend$GdbServerStep$1@12534fd): Status OK: unknown code=0 OK null' resulted in a rejected execution exception. null, done() method called more than once

    There is no P&E update site configured in KDS 3.0.0.

    Using a "GDB OpenOCD Debugging" configuration works correctly.

    Any pointer to solve the problem is welcome.



  • Greetings,

    Self-made cable was the key detail and I already know the answer. Once you use our JTAG/SWD adapter you will not longer see the problem. The reason for that is we have to short pin 7 (TMS) and pin 13 (TDO) to enable SWD protocol. The cyclone max was created before the SWD protocol was introduced, where there is a bidirectional TMS/SWD_DIO signal. The cyclone max port E is standard ARM JTAG where TMS and TDO were separate signals.

    Takao Yamada

    • Self made cable should not be the problem since I already shorted pins 7 and 13.

      I am starting a new design. When I did my firsts tests with FRDM-K22F, I used Cyclone MAX successfully with this board.

      Now, this does not work anymore.

      There's a strange behaviour : When the target is powered up, the flashed program runs. On board reset button does its job. After trying to connect with Cyclone MAX, the target is frozen and on board reset button does nothing (the processor is still frozen). I have to power cycle the target to make it run again.

      • I confirm the cable is not the culprit.
        I had the same problem with P&E official cable.
        However, after some modify and try iterations, it works correctly now. Software and hardware (jumpers) have to be both setup in a correct way.

        Working with Cyclone is a pleasure. It is much faster than OpenOCD interface.


  • I have the same problem with the Multilink FX and a USB connection.  Also has a self made cable, which worked fine with a different processor and IAR.  Also works great with PROGACMP.  Does not work with CodeWarrior 10.6.4. 

    Whatever cables came with the Multilink seem to have gotten lost. I don't see any listed for sale under Accessories. Do you sell a box of cables by themselves?

    • Greetings,

      You can find all of our ribbon cables on sale here:

      So same setup worked in PROGACMP but not in CW10.6.4? That is unusual. Which processor are you using? Did you check to see if you had SWD checkbox and same debug shift frequency settings?

      Takao Yamada

  • It's a KM64FX512.  I discovered that I had the SWD box checked in CW.  I also did not have the erase memory box checked.  Fixing both of those gets me to where I can download code, and execute it. 

    Now, setting a break point breaks the connection to the debugger. Know anything about CORBA connection errors? I am downloading to, and executing out of, flash.

    If I download to RAM, I get a "Runtime error 217 at 07E437B8" message, whatever that is.

  • Greetings,

    That is some forward progress. I want you to create a new project for your chip and debug it without making many changes to the settings. See if you have better luck. If so, then something in your project or settings is causing this behavior.

    If the default project also has problems, then we need you to reproduce the problem and report it in a support ticket. (Support page -> Support requests). I will have our KDS plugins and GDB expert take a look at the CORBA error you are seeing. (Screenshots are always good).

    Takao Yamada

    • I created a new project as you suggested.  It did nothing but flash one LED.  No change.  

      Then I downloaded IAR Workbench, and used it with the Multilink Universal FX, and my board. It worked perfectly first time, every time. Same for the Kinetis Tower setup. So the project is moving along, and this phase may be done this week; certainly by early next week. Although I would like to dig in and find the answer to CW Eclipse, I am contracting on this project, and probably won't be there long enough to find out what is going on.

      Thanks so much for your help.

  • Greetings,

    Any update on this?

    Takao Yamada

    • Sorry, the last message ended up in the wrong place.

Add comment

   Want to comment? Please login or create a new PEMicro account.

© 2018 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement