Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

Please accept the use of cookies on our site

At PEmicro we use web browser cookies in order to provide you with an enhanced experience and in order to be able to do things like shopping cart processing and identify you when you login to our website.

Click here to accept

search inside this forum
search inside all forums
Cyclone Max firmware update fails
Mark E. May 27, 2015 at 12:43 PM (12:43 hours)
Staff: Takao Y.

  • Hi,

    I had firmware rev 7.73-6.2 installed on the Cyclone Max. I downloaded the latest tools from the site (Image Manager went up from 3.10 to 5.21.00). On next start Image Manager it said the firmware needed to update to 7.85. That failed and the Cyclone is now reporting its firmware version as 7.51b.

    I've tried updating again and I sometimes I get a "Can't erase Main Kernel Image firmware block" message or sometimes a "failure after resetting device" message. I've tried connecting with USB and RS-232 with similar results.

    What next?

    Thanks, Mark


    • Bizarre. After leaving the Cyclone unpowered for 24 hours, I thought I'd try again. Worked first time. Possible I wasn't leaving it unpowered for long enough when resetting yesterday?

  • Greetings,

    That is odd. There is no need to unpower for a long time for it to work. Well, the important thing is that you got it updated. Do you have any questions or concerns with the latest firmware?

    Takao Yamada

    • No questions or concerns, thank you. Mark

Add comment

   Want to comment? Please login or create a new PEMicro account.

© 2018 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement