Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

Please accept the use of cookies on our site

At PEmicro we use web browser cookies in order to provide you with an enhanced experience and in order to be able to do things like shopping cart processing and identify you when you login to our website.

Click here to accept

search inside this forum
search inside all forums
Cyclone for ARM Error Code 2
Rafael S. Apr 23, 2015 at 04:10 PM (16:10 hours)
Staff: Takao Y.

  • Hi,
    I'm trying to store an image to Cyclone for Arm. The chip is actually a MKW21D256VHA5, but we're defining it as a K21DX256VMC5 in the IDE for various reasons. The question is, where does the Image Creation Utility get the information for which chip it's trying to program? I tried using the KW21D256m5 file and the 4 different K21DX256 files, but all of them result in the same error ("Error Code 2: Error reading S record file or appropriate CSAPxx file not found").
    What might the issue be here?



  • Greetings,

    Within the Cyclone for ARM software package, you will find the PROG for ARM software (PROGACMP). Use this to help you debug the issue. Trying to debug a scripted image is going to be very difficult to find the issue. If you can get it working in PROGACMP, then you will be able to transfer over to image creation very well.

    What file format/extension are you using as your object file that you are attempting to program? You should be using an srecord file (S19) or an ELF file.

    The creation utility knows which chip is it trying to program from the device selection. It is the option at the very top of the utility. The algorithm you select tells the cyclone which chip it is trying to program.

    Takao Yamada

  • Hi,
    I was able to get it to work with a newer version of the Image Creation Tool. I have both a Cyclone Pro and a Cyclone for Arm; the default Image Creation Tool was loading out of the Cyclone Pro directory and seems to be an older version (3.61).
    Loading the tool from the newer Cyclone for Arm directory works just fine (5.21)


Add comment

   Want to comment? Please login or create a new PEMicro account.

© 2018 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement