Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

Please accept the use of cookies on our site

At PEmicro we use web browser cookies in order to provide you with an enhanced experience and in order to be able to do things like shopping cart processing and identify you when you login to our website.

Click here to accept

search inside this forum
search inside all forums
Unable to Erase and Flash using P&E debugger using CW5.9.0
Haidarali N. Dec 29, 2014 at 07:37 AM (07:37 hours)
Staff: Takao Y.

  • I am using Freescale Codewarrior IDE 5.9.0 and P&E debugger (USB QORIVVA Multilink for MPC55xx/56xx Devices) to flash Freescale-MPC5668 uC. However it is not possible to do so. Debugger window gets hang while it is Erasing. I am using 1000000Hz as BDM Communication.
    Please let me know ASAP if there is any settings needs to be done to solve this problem

    Thank you !!


  • Greetings,

    Try lowering the debug shift speed. 1Mhz you are using is the fastest communication speed. Continue to drop the speed until you get reliable connection with your target.

    If that does not work, you should look into your schematic and see if you have any reset circuitry. If so, try adding a delay after reset of 200ms.

    Takao Yamada

    • Thanks Mr.Takao!

      I have created a simple project form Code warrior with a simple for loop to increment a variable and trying to download it to MPC5668E.

      I tried with all possible BDM communication speed,It still doesn't work.
      As for reset circuitry,I don't have any such circuitry.
      The ICDPPCNEXUS Debugger hangs with EM command saying Erasing.Nothing happens after that.

      Is there any scripting changes need to be done?
      Your help is much appreciated in getting this issue resolved.

  • Greetings,

    No scripting changes are necessary. Hanging at EM means two things. It was initially able to talk to your target chip. But then it failed to maintain that communication. A few things can cause this.

    1) Try replacing the ribbon cable, especially if you have used the multilink many times in the past.

    2) Are you using any custom ribbon cables, adapters, system bus chip, external watchdog, or other unique hardware? Are you connecting all 14 pins of JTAG to the multilink?

    3) Without the P&E multilink connected, measure the chip's voltage. Is it being properly powered? Hanging at erase can mean the chip is not getting enough power and it is stuck.

    Takao Yamada

  • Greetings,

    Any update on this?

    Takao Yamada

  • Thanks for the suggestions.

    1)I checked the debug cable.It is working fine.I also tried with newer cable.

    2)We are connecting a 14 pin debug cable from Debugger to JTAG pins of the board.

    3)Board is powered up correctly.

    Is there any security for erasing and flashing of the Microcontroller??

  • Greetings,

    There is no security for erasing and flashing, unless you made changes to the shadow block of the flash. If you accidentally erased or incorrectly modified the shadow block, then your chip may be permanently secured.

    If you know the chip is blank and has not been programmed yet, then you should not have to worry about security.

    You may need to start measuring voltages or using an oscilloscope of the JTAG signals to see what may be going wrong. Are you sure you do not have any kind of system bus chip or external watchdog? More and more I have seen board designs with system bus chips that are causing many customers headaches.

    First, monitor the reset line and TVCC to see that nothing with your power is giving you problems. Then move onto monitoring the TDI, TDO, and TCK.

    Takao Yamada

  • Greetings,

    Any update on this?

    Takao Yamada

Add comment

   Want to comment? Please login or create a new PEMicro account.

© 2018 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement