Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

search inside this forum
search inside all forums
No Port shows after Refresh for an "OpenSDA Embedded Debug - USB Port" interface
David l. Aug 10, 2014 at 05:08 AM (05:08 hours)
Staff: Takao Y.

  • I have purchased an FDRM-KE02Z40M evaluation board.

    Drivers have been installed, and in Device Manager I see a COM port called:
    "OpenSDA - CDC Serial Port (http:/ (COM3)", as well
    as a COM1 conventional COM port.

    First of all, when I run the Basic P&E GDB Server for Kinetis (Limited version), it has "unlicensed" at the top. If I hit the Update License icon, and copy and past the installation code and activation code given to me, it says there is an error. It only says that the codes are OK, if I uninstall, and do a complete reinstall. Despite doing that, the top still says "P&E GDB Server ... (Unlicensed)"

    When I select "Open SDA Embedded Debug - USB Port" as my interface, and irrespective of whether I hit Refresh, no Port shows up, not COM1, nor COM3.

    Does anyone know what I am doing wrong?

    I have everything at installation default - localhost, start server on Startup are selected.

    I have tried to Stop the Server, and then do a Refresh, and then restart the Server, as well as doing a refresh with the Server started.

    I am not sure what "device name" to select. The micro is a MKE02Z40M, and the closest I can find is a KE02Z64Mx


  • Greetings,

    When you connect your OpenSDA USB connection you should see two items within device manager pop up. You should see the CDC serial port which you have already seen, and you should also be seeing "PEMicro OpenSDA Debug Driver" under the "Jungo" listings. If you do not see this, then you will not see OpenSDA in any software. If you see the "!" symbol by it, then you need to reinstall the drivers by right-click and reinstall.

    If you do see the debug driver but still cannot connect, it could be that you have the port open in another software or another instance. Make sure you only have one software working with the OpenSDA port.

    Takao Yamada

    • Thank you for the response.

      Under the Jungo listings, I see only "WinDriver".

      I have installed from the FRDM-KE02Z40M module, or by downloading the SDA driver from P&E.

      The results are the same.

      I think I am going to have to redesign my hardware. I have wasted weeks trying to talk to this module, upon which my SW development plans were all based.

      As far as I can tell, Freescale have sold me something that just does not work.

  • Greetings,

    I am sorry that you are having such difficulty with this interface. Do you not see the "PEmicro OpenSDA Debug Driver" anywhere in device manager? Check for any "!" symbols. The board should work perfectly fine as we have two of these boards here and did not have any issues. Make sure not to use any USB hubs that are not externally powered as the OpenSDA board needs the power from the USB connection.

    Takao Yamada

  • No.  I never see the "PEMicro OpenSDA Debug Driver".

    I have 2 USB3.0 ports on the front panel, and two 3.0 ports on the rear, and the rest are all 2.0 ports.

    I have tried connecting to most of them, and it makes no difference.

    I assume my module is getting power because it powers up. The blue LED comes on first then a Green one near the connector, and then the Blue LED flashes, and then flashes Green and then it will stay off for a while, but if I keep touching, or moving the board, the Red/Blue flashing keeps happening.

    Is that the normal LED sequence?

    Is there some jumper I need to remove/add?

  • Greetings,

    One more thing to check is if you see "BOOTLOADER" show up in device manager. If you see the green LED blinking, then that means the board needs an OpenSDA firmware to be loaded before it can function correctly. You can force your board into bootloader mode by holding down the RESET button (usually near the USB connector) and connecting the USB cable. Then release the RESET button and you should be in bootloader. Try drag and dropping a new firmware into the bootloader. You can get these firmwares from our website under firmware apps. Make sure to select the MSD-DEBUG firmware for FDRM-KE02Z:

    Unfortunately I do not know the default program running on the board so I have no clue if the red and blue flashing LEDs mean anything.

    By the way, I have confirmed that our GDB server application has a bug where even if you register your installation code, the application still says it is unlicensed. But no worries, the application is in full activation. We will fix this in our next release.

    Takao Yamada

  • Greetings,

    Were you able to get your board working?

    Takao Yamada

Add comment

   Want to comment? Please login or create a new PEmicro account.

© 2019 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement