Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

Please accept the use of cookies on our site

At PEmicro we use web browser cookies in order to provide you with an enhanced experience and in order to be able to do things like shopping cart processing and identify you when you login to our website.

Click here to accept

search inside this forum
search inside all forums
Cable12 and BDM MultiLink not working
Joseph B. Jun 11, 2014 at 07:22 PM (19:22 hours)
Staff: Takao Y.

  • We have an old PC with Win98SE that is used with the CABLE12 to verify a product. Yesterday when trying to run Cprog12Z.exe, its window would open and close quickly. Using the camera on my phone I captured the error message that is briefly displayed on the screen. 
    It's states "CMD>RE ;Reset the MCU", the second line states, "Cannot enter background mode. Check connections."
    We first replaced the ribbon cable on the CABLE12, but that didn't help. So after some further t-shooting and not finding any problems with the unit under test and trying a reference unit, we ordered a replacement for the CABLE12, which is the Parallel Port BDM MultiLink. We received that this morning and it acts the same. I then downloaded a new driver for it from P&E Micro website. But there was no change.
    The shortcut has the following commands:
    C:\pemicro\progw\cprog12z.exe ? 1 io_delay_cnt 3 c:\9061fix\d60a_eeprom.cfg v

    What could be causing the CABLE12 or the BDM MultiLink to act this way?


  • Greetings,

    1) Has this setup worked in the past? Or is this a first attempt?
    The command looks to have an extra parameter "1" in it. Try the following:

    C:\pemicro\progw\cprog12z.exe ? io_delay_cnt 3 c:\9061fix\d60a_eeprom.cfg v

    2) Another thing to try is checking to see if your chip is secured. You did not tell me which chip you are working with but if your chip is a HCS12 or HCS12X, then it is possible that it is secured and having troubles entering background mode. Use the following utility and try unsecuring the chip:

    3) If the first two did not solve your issue, please tell me what is inside your CFG file located at c:\9061fix\d60a_eeprom.cfg. I would like to know if the commands inside the CFG file is incorrect.

    Takao Yamada

  • Takao, 
    Yes, this setup has worked for many years. It just started giving us problems and we first believed it was a bad cable. The tech replaced it with a spare and we still had the same problem. Then we noticed that the current draw went up 400mA with the CABLE12 installed. That's when we ordered the BDM Multilink Interface.
    I also didn't understand what the "1" after the "?" was for and have tried running without it with unfortunately the same results.
    The chip is a Freescale MC912D60AVPV8.
    With the BDM Multilink, we are now getting an Error 43 - invalid command line parameter.
    We tried adding "Interface=BDMMULTILINK Port=1" to the command line today and we had the same result.
    I check with the ICT Engineer and the IC is not secured by them.
    Here's what's in the CFG file:
    RE ;Reset the MCU
    CM c:\9061fix\Freescale_912D60A_1x16x512_1k_EEPROM.12p ;Enable 912d60a eeprom
    EM ;Erase the module
    Like I stated in the beginning, we've been running this for many years without a problem. I think the CABLE12 (Rev. D) just finally gave out. The replacement isn't exactly the same and we need to figure out what we need to change for it.
    Thank you for your help. I look forward to trying anything else you can suggest.

  • Greetings,

    Your chip does not support security so there is no point of trying to unsecure it.

    What you should do is first try your setup in regular PROG12Z, the non-command-line version of the software. It should be located in the same directory as your CPROG (C:\pemicro\progw\prog12z.exe). It is a step-by-step GUI software that can be helpful in finding your issue easier because it does not run your commands in an automated script. See if you are able to connect your target board and be able to erase/program/verify it with no problem.

    Takao Yamada

  • Takao,
    Thank you for your Help. I was able to locate the problem with the command-line parameter. Running PROG12Z, I was still getting the same errors about the connection but I was able to run the auto-detect option for the io_delay_cnt. Although, I had to run it several times because I was getting different values and each still would not work and it kept telling me I had a connection error. I verified the ribbon cable and everything passed. Probably the header on the ribbon cable was not making a good connection, so I replaced it and was able to get further with the PROG12Z program. The PROG12Z program finally told me that the delay value was 27, consistently. I was also able to run the RE, CM and EM commands individually. So, I replaced the 3 in the io_delay_cnt command with 27 and ran that and it finally ran as it used to. So apparently, the delay is different between the CABLE12 and the MULTILINK Interface Modules.
    I am still having an issue with the unit after programming it but I think that's another issue not related to the Interface Module.

    Thank you again for your help.

  • Greetings,

    Yes the delay will definitely be different between the CABLE and the Multilink. It may even differ between similar multilinks. It is best to allow auto-detect the communication speed, however it does take a few seconds for it to detect.

    I am glad you were able to get more forward progress and I hope you are able to resolve your new situation.

    Do you have any other questions or concerns?

    Takao Yamada

  • Takao
    No, I don't have any more questions on this. I do really appreciate you time and help. The units are fully working again.

    Thank you again,

Add comment

   Want to comment? Please login or create a new PEMicro account.

© 2018 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement