Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

Please accept the use of cookies on our site

At PEmicro we use web browser cookies in order to provide you with an enhanced experience and in order to be able to do things like shopping cart processing and identify you when you login to our website.

Click here to accept

search inside this forum
search inside all forums
ICD08sz.exe is not detecting in the P&E Cyclone pro with latest driovers
Anna K. Jun 11, 2014 at 07:31 AM (07:31 hours)
Staff: Takao Y.

  • Hi,
    I had installed the PEDrivers_install.exe from the P&E site for the Wind7 machine and now i am able to program the controller HC08 QC16 using the Programmer ( pkg08sz.exe), but when i launch the ICD08sz.exe it is not detecting when i selected the option as P&E Cyclone pro connected with ribbon cable.It shows USB not detected. But when i tried with the pkg08sz.exe it shows that USB connected is Cyclonepro. So i just wanted to know the PE Drivers are compatible with both the programmer and the debugger?

    Please help us to resolve this issue


  • Greetings,

    Could you try downloading the PKG08SZ software from our website?:

    I just rebuilt them just for you and hopefully they will work with the latest operating systems and drivers.

    Please let me know if you still run into problems or if things worked out for you.

    Takao Yamada

  • HI Takao Yamada,

    Thanks for your latest installation file. Now it was working fine with out any issues. I am able to see that ICDS08sz is detecting the Cyclone pro as USB.
    And i need one more help also.
    We have the other unit called P&E USB MONO8 Mutlinik hardware. But we don't have the drivers for it. Can you please provide me the installation driver file for that too?

    • Hi, 

      We are able to see that ICD08SZ is detecting the Cyclone pro and able to open the GUI.But when we load the symbol file it was giving some errors/warnings.

      command was given like this :

      HLOAD appl.695

      after that i am getting error like below.
      Note - Execution Start record not found. Start Address = $0000000
      WARNING!!!!! Access Violation at address 004CBD3 in module icd08sz.exe write of address 0000000D

      Can you please share me your mail id so that i can send my screen shots to that.

  • Greetings,

    You do not need separate drivers to get your other P&E interfaces to work. You can simply connect it to your computer and it should be working on your ICD08SZ. The blue LED on the multilink should also be lit.

    If not, you should maybe reinstall the PE drivers:

    Takao Yamada

    • Thanks. But i tried with the above mentioned drivers. we are not still able to see that MONO8 Multinik hardware is getting detected by the PC.

      Please help us.

  • Greetings,

    Is the blue LED turning on? If so, then the drivers were installed correctly and it is a problem of the software that is not detecting it. Make sure within the software that you have the Multilink as the hardware selection.

    If the blue LED is not on, then the drivers were not installed. Go to your device manager and look for "Jungo". Within, you should find "WinDriver", and "USB Multilink 2.0" if you have your multilink connected. If you see any "!" signs, then that means something went wrong. Let me know what you see in the device manager and I can assist you from there.

    Takao Yamada

    • Yes BLUE LED is glowing. But still i am getting a message like 
      Device Driver Software was not successfully installed.
      Please consult with your device manufacturer for assistance getting this device installed.

      P&E USB MONO8 Multilink ------ No driver found.
      And in the Device manager i am seeing that Jungo-> WinDriver but not showing the USB Multilink 2.0

      And one more thing is in Other devices ---> P&E USB MONO8 Multilink with some signs like "!" signs as you mentioned.

      • Can you also reply to my comment 3.1

  • Greetings,

    To answer comment 3.1, I think it is best if you could create a support request ticket via the support page. Please put my name somewhere and it will be assigned to me. Then you can post screenshots.

    Within device manager, right-click on P&E USB MON08 Multilink and uninstall. I think what is happening is older drivers were used and now it is in conflict with the newer ones.

    Once uninstalled, disconnect and reconnect the multilink and see what happens. Hopefully it will get resolved.

    Takao Yamada

    • I tired the uninstall drivers. Then removed the USB and re connected. still it was showing the same error like
      P&E USB MONO8 Multilink ------ No driver found.

  • Greetings,

    I just learned that revision B or earlier of the MON08 Multilink will not work on 64-bit machines. You need a rev C or higher to get it working on the latest operating systems. Please check to see what revision you have.

    Unfortunately, this either means you will need to use an older machines like XP 32bit or buy a new multilink. You could try a virtual machine, but we do not guarantee it will work.

    Takao Yamada

    • Thanks for the info. Yes we are using the USB Mono8 Multilink Rev A. 

      We tried on virtual machine as well but didn't work.

  • Greetings,

    I am sorry that it did not work out. Microsoft stopped supporting certain driver chips in their latest operating systems and the Rev B or earlier had its support discontinued. So we had no choice but to stop support for these older hardware. Our rev C or newer have support working in all of the latest operating systems.

    Do you have any other questions or concerns?

    Takao Yamada

    • Ok. I think P&E MONO0 Multilink option was ruled out now.

      What about the P&E Cyclone Pro ? i think this was detecting the drivers. But i am still not able to proceed to the Debugging for loading elf/.695 files.

      do you have any support on this?

Add comment

   Want to comment? Please login or create a new PEMicro account.

© 2018 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement