Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

Please accept the use of cookies on our site

At PEmicro we use web browser cookies in order to provide you with an enhanced experience and in order to be able to do things like shopping cart processing and identify you when you login to our website.

Click here to accept

search inside this forum
search inside all forums
Botched bootloader update
Alex A. May 17, 2014 at 09:49 PM (21:49 hours)
Staff: Takao Y.

  • It looks like my attempt to update the bootloader on my brand new FRDM-KL26Z has resulted in a bricked board. No LED powers on anymore. I'm just starting to learn ARM board development, and this is my first one. Any pointers would be appreciated. (The readme file says I need to mail my board to PEMicro if I need to fix a bootloader)


  • Greetings,

    There was another customer who had a similar problem and this link below helped them get out of a bricked unit. See if you can follow their suggestions and get you back to working order:

    Takao Yamada

  • Greetings,

    Were you able to get your board working again?

    Takao Yamada

    • Hi Takao Yamada,

      Thanks for replying. I'll give it a try as soon as I'm home from work today.

      - Alex

  • Greetings,

    Any update?

    Takao Yamada

    • Haven't gotten to test it yet. I'll have to try tonight.

      If that doesn't work, what other option is there? What is the common approach to getting a bootloader on an ARM chip? JTAG? 2-Wire? I'm learning about ARM, so any information is good.



  • Greetings,

    JTAG would be the most popular way of programming the bootloader or any code in general. I guess you could program with 2-wire but good luck trying to debug it if you see any problems. Great thing about JTAG is that it is a widespread protocol and allows both programming and debugging capabilities. If you have the right tools, you can even do external trace using JTAG so you can see the real-time behavior of the chip.

    Takao Yamada

    • Ok, I tried simply connecting a USB cable to the OpenSDA port, with the kl26z "Reset" button pressed, and again with the "Reset" button unpressed, with the Kinetis Recovery Utility open (I'm using a Windows 7 laptop for this, as there wasn't anything obviously for linux).

      The Kinetis Recovery Utility does nothing. I tried clicking "Start" using the "Show Hardware" option, and the OpenSDAUSB option.

      Since it appears I will need a JTAG debugger, I've purchased an Olimex ARM-USB-OCD-H device, in the hopes it will be usable with this board. If you have a better recommendation, let me know. I don't want to give up on these really cool boards just yet.

      I think I can reuse a 2.54mm to 1.27mm pitch 10-pin adapter to connect a JTAG debugger to the smaller pin layout of the kl26z.

      No solution yet, but I'm going to keep trying.

  • Greetings,

    You cannot recover the board by trying to connection to OpenSDA within the Kinetis Recovery Utility. You are going to need an external JTAG debugger. My suggestion is to purchase a multilink called the USB-ML-Universal because not only can it debug ARM Kinetis, but it also supports 5 other architectures from Freescale:

    I am not familiar with Olimex, but with this tool you cannot use our recovery utility. You will most likely need to create your own recovery tool if you know what you are doing.

    Once you get the multilink, try to follow step-by-step already detailed in the link I already gave you:

    It is going to take multiple attempts to recovery your board even with the correct setup.

    Takao Yamada

    • Hmm...OK. It looks like that programmer costs 10x more than the board. I just purchased another board instead. I'm just trying to evaluate ease of use, tools available, and community support. So far, I am happy with the support. It appears KL26z doesn't support BIN file, so... can it work w/ mbed?

  • Greetings,

    The programmer does indeed cost more than the board but it will be useful once you decide to create your own board/prototyping stage because the OpenSDA option is only found on these Freedom boards for evaluation. It is one of the cheapest solutions on the market and it works with many IDE's and supporting softwares.

    Currently the OpenSDA on MKL26Z supports S19 files. If you have a BIN file, we do have conversion utility to switch it to an S19 file, called BIN2S19:

    Let me know if you run into issues with the new board. Remember to not program over the SWD or JTAG pin signals. This can easily brick your board.

    Takao Yamada

  • Greetings,

    Were you able to get your new board working? Do you have any other questions or concerns?

    Takao Yamada

Add comment

   Want to comment? Please login or create a new PEMicro account.

© 2018 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement