PEmicro logo
Cart New Account Login

Logo image
HomeAbout usProductsSupportForumsBlogCustomer Service

search inside this forum
search inside all forums
Multilink universal problems with connection USB and update
David G. Oct 6, 2020 at 10:17 AM (10:17 hours)
Staff: Takao Y.

  • Hi,
    I have a multilink universal debugger used with Code Warrior for ColdFire v5.7.0 and uC Freescale ColdFire 5222x. It can't connect to PEMicro via USB.
    I've installed latest mulitilink drivers v12.7.0 and later I've update multilink firmware to v10.46 witch select "Colfire V234" architecture.
    The first time that I try debugging with Code Warrior it start to "update" multilink firmware to versión v5.39 and fails with error "Flash Erase Failed. Result = $8882".
    How can I use multilink debugger with this setup?

    Thanks!




    Comments

  • Hi Takao,

    I tried the patch but it doesn't work.
    Later I tried other things until I finally solved my problem:
    - I reinstalled CodeWarrior in order to undo any change.
    - I installed PEMicro drivers v11.7
    - I downgrade Multilink firmware to versión 9.92 (important this step). I used PEFirmwareConfig.exe
    And then I could debug my code!

    I also had other new Multilink Universal that didn't work either. With sames steps now also works.

    Best regards,

Add comment


   Want to comment? Please login or create a new PEmicro account.







© 2021 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement