PEmicro logo
Cart New Account Login

Logo image
HomeAbout usProductsSupportForumsBlogCustomer Service

search inside this forum
search inside all forums
Multilink Universal FX
Fritz Erik P. Sep 14, 2020 at 02:24 PM (14:24 hours)
Staff: Steve M.

  • My Multilink Universal FX, have worked flawlessly for years, but are now occasionaly showing up as not connected. This is happening after connection to target are made. When just plugging in USB cable and start the PROGZ32 software it seem like normal, but as soon as connection to target are made there are the sound from PC telling that cable are disconnected and reconnected, and this is going on and on. I am currently running Windows 10 on tha affected computer, and I have tried the Multilink on an older computer still running windows 7 without any problem at all. Could it be any problem with drivers for windows 10.
    I have tried to run drivertest, and this came out OK. I have tried to deactivate device, uninstall drivers, reinstalled drivers, with no effect.
    Any suggestions.


    • Hello,

      Generally, an issue like this occurs when there is an incorrect connection to the target. If you are able to view the Multilink initially, then the drivers seem to be okay. If the issue arises after you try to connect to the target and then the Multilink is no longer recognized in PROG, I would double check your ribbon cable connections or even try a different ribbon cable. Make sure all power connections are correct as well. Are you powering the target externally or through the Multilink FX?


  • Hi
    I am powering the target externally, throught the Multilink does not seem to work for this type of control unit. The ribbon cable are self made, however it work well when I use the same setup with the same Multilink on my Windos 7 computer. This led me believe that the connection itself should be OK. On this computer all operations work as intended, reading, erasing and programming as normal. I have succeeded in some occasions to perform read, erase and programming on my windows 10 computer, but mostly it will not work. If I open the device manager it will keep "refreshing" all the time, however not when only the multilink are connected, but as soon as I connect to target this starts.

Add comment

   Want to comment? Please login or create a new PEmicro account.

© 2021 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement