PEmicro logo
Cart New Account Login

Logo image
HomeAbout usProductsSupportForumsBlogCustomer Service

search inside this forum
search inside all forums
error during script programming MK64FX512VLL12 with CPROGACMP
. Jan 10, 2020 at 07:56 AM (07:56 hours)
Staff: Gilbert Y.

  • Hi happy new year every one,

    I am using a FX Multilink Universal, and I'm trying to program an MK64FX512VLL12 with CPROGACMP.

    When I run my script, it fail and I have an error 15. But I have also error loading .arp.

    I have chosen the correct device and the path of the .arp file is also correct.

    Whith PROGACMP, I can program my µC with the same path for .arp file and the same device.



    Can anybody have an idea?

    Thanks for help.


    • Hello,

      The links that you provided for images appear to not be available or not visible to me. Can you instead copy and paste your command line arguements and .cfg file here for me to view? You can remove any confidential file paths if you need and substitute them with dummy ones.

      How is your target connected to your device and how are you powering it?

      Gilbert Y.

  • Hello,

    Sorry I don't understand why the link not working.

    My target is powered with 3.3V coming by a regulator and connected to the device from tests point.

    Here my .cfg file:
    CM C:\PEMicro\PROGACMP\supportFiles_ARM\NXP\K6x\freescale_k64fx512m12_pflash_dflash_eeprom.arp
    :DEVICE Freescale_K6x_K64FX512M12
    SS D:\L4832\Exe\PEL106\696080A00 - LOG.BAS PEL104106 1.00.hex



    I hope the new links works.


    Abdi Guelleh.

    • Is there any change in your hardware setup when you try to program using CPROGACMP? Are the devices pre-programmed or are they erased prior to attempting to program in CPROGACMP?

      What revision of MultiLink are you using?

      • Hello,

        Did the links works now?

        I did not change my hardware when I programmed the µC with PROGACMP and CPRGRACMP.

        I am doing a test bench of an electronic card. The tests are automatic.

        The µC and the multilink are powered by the same regulator in 3.3V.

        The multilink connected to the µC by tests points.

        It's complicated to explain correctly the connection between the multilink and the µC, so here a synoptic and picture how i m doing my connection:


        The µC is not programmed at the begining, I program the µC and after I do the tests.

        I erase the module before programming if in case a new firmware have to be upload in a card programmed.

        The revision of the multilink is 7.09.

        Thanks for help.


        Abdi Guelleh

        • Yes, the links work now.

          I attempted to recreate your issue on both our K64F and K70FX test board but can't seem to recreate this issue. Is there anything special being programmed onto your device prior to connecting in CPROGACMP that would prevent you from running code?

          • No, nothing is programmed, I do this at the begining before anything else.

            I have a main script that do every tests automatically for the test bench and the first thing I do is to power the card tested and run a second script that program the card.

            When the programming passed the second script closes and it return at the main script and do the tests.

            Do you know why in CPROGACMP the console says first "Device is secured. Erasing"?

            It attempt to erase something I did not write in my script, and that takes a long time and after it fail to charge the .arp file.

            Whith PROGACMP I don't have that.

            • I had assumed that you had performed the "SD Secure Device" command, but if that is not the case, that means that you may be programming the byte responsible for chip protection by mistake as part of your test. This is the FSEC[SEC] bit, which is outlined in Chapter 8 and (which leads to 29.3.1) of the K64 reference manual. The Flash Security Byte is at address 0x040C.

              Are you able to reconnect to the device even after it fails in CPROGACMP?

              • Yes, I am able to reconnect to the device.

                Example: Programming fail in CPROGACMP, rigth after I do the same command manually with PROGACMP and programming pass.

                I don't program the flash security byte.

                • Would it be possible for you to provide the .hex file that you are programming to the device for us to test? This will require you to open a support request with us so we can exchange files.

Add comment

   Want to comment? Please login or create a new PEmicro account.

© 2021 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement