Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

search inside this forum
search inside all forums
Debug Error 45 using Multilink ACP / Keil / NXP Kinetis
p t. Oct 26, 2019 at 06:05 PM (18:05 hours)
Staff: Gilbert Y.

  • Hi I've been successfully using Multilink ACP on Keil 5.28a for about a month now.  In the middle of working today all of a sudden it started crashing the IDE when I go to debug.

    It connects OK initially, window pops up and says "Initializing. Target has been reset and is active.", and I get the usual Keil "EVALUATION MODE" nag dialog.

    Then the error pops up in the next CPROGACMP window:
    Notice - USB driver did not initialize. (1234BEEF)
    - Library=PEUSBMGR2.DLL
    ERROR 45 during script!

    ...and then Keil hard crashes.

    I've tried reinstalling everything - Keil, USB drivers, PnE support, nothing seems to fix it.

    I tried the driver test software I found in a similar post, it gives me this output:
    (detected) C:\WINDOWS\sysnative\drivers\pemicrowindrvr.sys (Version 12.03)
    (detected) C:\WINDOWS\syswow64\peusb32bin64os.dll (Version 12.03)
    (detected) C:\WINDOWS\syswow64\peusb64bin64os.dll (Version 12.03)
    (detected) C:\WINDOWS\syswow64\peusbmgr.dll (Version 6.123)
    (detected) C:\WINDOWS\syswow64\peusbmgr2.dll (Version 6.123)
    (detected) C:\WINDOWS\syswow64\peusbmgr264.dll (Version 6.123)

    When I try to run the Firmware Update utility, the device is undetected, but not sure if this means anything.

    I'm on Windows 10 v1903. Anyway, not sure what to try next, hoping for help.



    • Hi Peter,

      There is a temporary workaround for this issue. Please refer to the following forum post:

      If you have the time, we would like to provide you with an updated dll that logs any major crashes that we may run into. We can then take this log from you and use it to determine the root cause of the issue. If you are interested, please open a support request with us and mention this forum post.

      Gilbert Y.

    • With regards to your device being undetected, is this after you have unplugged and plugged in the USB cable? Sometimes after a crash, the USB port connection can be held without Keil being open, so manually disconnecting it should fix that.

      • Hello Gilbert,

        This did fix me up thank you!

        Thanks a lot for the support :)

Add comment

   Want to comment? Please login or create a new PEmicro account.

© 2021 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement