Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

search inside this forum
search inside all forums
Error using Multilink FX to debug with S32DS
. Oct 21, 2019 at 07:09 AM (07:09 hours)
Staff: Takao Y.

  • Hi All,

    I am trying to use a Multilink Universal FX Rev A to debug code on a MPC5744 / S32DS IDE. I have installed all the plugins on S32DS, installed the PE Multilink supported CD files, updated the PE Micro Firmware, etc.
    It seems the S32DS is expecting the tool to use a different version GDB.exe, I could not find any solution for this so far.
    When I try to debug/program the target I get the following error:
    " Error while launching command: C:\Users\orlando.martins\Documents\MATLAB\Add-Ons\Toolboxes\NXP_MBDToolbox_MPC57xx\code\tools\Cross_Tools\powerpc-eabivle-4_9\bin/bin/powerpc-eabivle-gdb --version "

    Has anyone experienced the same issue?




  • Greetings,

    Bizarre that your GDB is tied to MATLAB. You should be using the GDB found within S32 Power IDE install. Mine is found here:

    Takao Yamada

    • Hi Takao,

      Many thanks for replying on this topic.
      The wrong path was my mistake because it was not working with the default path and the I tried with a different version of gdb I had installed.

      Rolling back the original path I still get the same error:

      " Error while launching command: c:/NXP/S32DS_Power_v2017.R1/Cross_Tools/powerpc-eabivle-4_9/bin/powerpc-eabivle-gdb --version "

  • "Could not determine GDB version after sending: c:/NXP/S32DS_Power_v2017.R1/Cross_Tools/powerpc-eabivle-4_9/bin/powerpc-eabivle-gdb --version, response: "

  • Greetings,

    I would uninstall all the plugins and ONLY install the E200 plugin. There is only one to install. Possibly by installing the ARM plugin is causing you issues.

    Takao Yamada

    • Good point Takao, I had done that already. but no luck. Any other ideas?

  • Greetings,

    Switch back to the default:
    as the path and try again.

    I cannot think of anything else that would cause this problem. Try running S32 as Admin. Another thing to try is opening CMD prompt and running that same path with the --version flag to see if you can get a version number.

    Takao Yamada

  • Hi Takao,

    Running S32 on admin mode does not help.
    Running gdb from a CMD prompt gave me the following:

    " C:\NXP\S32DS_Power_v2017.R1\Cross_Tools\powerpc-eabivle-4_9\bin>powerpc-eabivle-gdb --version
    GNU gdb (GDB rev=gceb1328 s=F494 -i /opt/freescale ELe200 -V release_gceb1328_build_Fed_ELe200_ML3 (BLD = 1607)) 7.8.2
    Copyright (C) 2014 Free Software Foundation, Inc.
    License GPLv3+: GNU GPL version 3 or later <>;
    This is free software: you are free to change and redistribute it.
    There is NO WARRANTY, to the extent permitted by law. Type "show copying"
    and "show warranty" for details.
    This GDB was configured as "--host=i686-w64-mingw32 --target=powerpc-eabivle".
    Type "show configuration" for configuration details.
    For bug reporting instructions, please see:
    Find the GDB manual and other documentation resources online at:
    For help, type "help".
    Type "apropos word" to search for commands related to "word". "

    Can it be mismatch between versions of gdb and S32 or something like thaat?

  • Greetings,

    What I have noticed is all the directory paths in your error messages you have posted are all using the forward slash, while all the paths I have posted are backwards slash which is more typical of Windows machines. Try switching your slashes in your path for GDB and see if that resolves your issue.

    Takao Yamada

    • Hello Takao,

      Thanks for keep trying to help on this.
      The backslashes do not help, still getting:

      " Could not determine GDB version after sending: C:\NXP\S32DS_Power_v2017.R1\Cross_Tools\powerpc-eabivle-4_9\bin\powerpc-eabivle-gdb.exe --version, response: "

  • Greetings,

    Go to Help -> Check for Updates and make sure you are running the latest plugin from us.

    Otherwise, I would uninstall and reinstall the whole IDE while also making sure to check for updates immediately after installing the IDE.

    Takao Yamada

    • Hi Takao,

      I did all of that but not joy in the end. Nothing seems to fix it unfortunately.

  • Hello Orlando,

    Are you putting ".exe" at the end of your gdb path in S32DS? A few of your log messages from earlier do not have ".exe" explicitly shown while your latest one does. I was able to to see the same issue when I did not include ".exe" at the end of the path after the executable name.

    Gilbert Y.

    • Hi Gilbert,
      Thanks for placing a comment. I corrected the path but the error is still the same.

      "Could not determine GDB version after sending: C:\NXP\S32DS_Power_v2017.R1\Cross_Tools\powerpc-eabivle-4_9\bin\powerpc-eabivle-gdb --version, response: "


  • Greetings,

    Any update on this? Were you able to find the problem? Seems bizarre that the path looks right and you are able to run it in command-line with no issues.

    Takao Yamada

  • Hi Takao,

    No updates. I had access to a Lauterbach debugger for a couple of days and I could program the micro. But PEMicro Mutilink is parked at the moment.


Add comment

   Want to comment? Please login or create a new PEmicro account.

© 2021 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement