PEmicro logo
Cart New Account Login

Logo image
HomeAbout usProductsSupportForumsBlogCustomer Service

search inside this forum
search inside all forums
Can't download another image to spc58
ARTEM R. Jun 28, 2021 at 04:20 AM (04:20 hours)
Staff: Takao Y.

  • Hello!
    I'm trying to use CYCLONE LC for flashing SPC58 using this configuration:
    RE ;Reset the MCU
    CM /PARAM1 ;Choose Flash Module
    SS /PARAM2 ;Specify the file to use
    PM ;Program the module with the file
    VM ;Verify the module
    SS /PARAM3 ;Specify the file to use
    PM ;Program the module with the file
    VM ;Verify the module again
    RE ;Reset the MCU
    G0 ;Run

    I can't download an image if has another image in spc58 flash.
    I need to full erase flash by another programmer from STM. After this procedure, I can program flash memory only once. If I try to load another image CPROGPPCNEXUS stucks in the programming step.

    I use CPROGPPCNEXUS.exe version

    How can I use this one to program different images to spc58?



  • Greetings,

    You shouldn't try to debug your problems with CPROG because it is all automated.

    Use PROG PPCNEXUS software and just step by step figure out what step is working and what steps are failing. PROG is found in the same folder as your CPROG.

    When you do get an error, be specific on what error message you get. "Can't download an image" tells me absolutely nothing.


    • Hello!
      I didn't get any errors. CPROGPPCNEXUS just stuck on the step PM (when I try to load another firmware which I give as PARAM). CPROGPPCNEXUS writes in Status Window "Checking range of S records. Checked.
      Programming Address $01000000"
      After this, the program freezes forever.
      I've tried the same in PROG PPCNEXUS and got the same results.
      If I try to load the same image which was downloaded before to SPC58 or do a full chip erase I don't have this issue. Maybe is it related to the license?

  • Greetings,

    License is not going to be the issue. That only unlocks a full version of the software.

    Freezing like that indicates there is a communication loss. I noticed in your order of commands that you do not check if the memory is erased or blank. This is unusual. Typical order of commands are:



  • Hello,
    Adding step EN solved the problem.
    Thank you.

Add comment

   Want to comment? Please login or create a new PEmicro account.

© 2021 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement