PEmicro logo
Cart New Account Login

Logo image
HomeAbout usProductsSupportForumsBlogCustomer Service

search inside this forum
search inside all forums
NXP LPC1768 fails on verify
Alcyr F. Jun 24, 2021 at 10:05 AM (10:05 hours)
Staff: Mika I.

  • Hi !
    I need to program in circuit a LPC1768 using SWD - Cyclone Universal . The erase and program steps works fine but the verify fails with code 5003.
    I use a fixture ( bed of nails ) and the cable is a litle bit long ( about 40 cm ). I tried with slowest clock but not sucess.

    Does anyone has experience with this issue ? Could you share some tips ?

    Thanks !!!




    Comments

  • Hi,

    Thanks for reaching out. We have seen communication issues with a bed of nails and with longer cables in the past, so it's possible that your hardware setup is related to your verification issues.

    But just to check, I suggest that you try the following:

    1. Do all of your testing in PROGACMP (i.e. C:\PEMicro\cyclone\InteractiveProgrammer\progacmp.exe), as it gives more detailed error information than Cyclone standalone does. Pay attention to whether the VM command always fails on the same address, or if it's somewhat random. If it's random, it may be a communication issue related to your hardware setup.

    2. Create a blinky led project and test whether or not you can erase, program, and verify with the exported object file. That could help narrow down whether or not your issue is related to your project.

    3. If you have a LPC1768 (or related) development board, you can try to program that board with a standard ribbon cable and see if verification still fails.

    Best Regards,
    Mika

Add comment


   Want to comment? Please login or create a new PEmicro account.







© 2021 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement