PEmicro logo
Cart New Account Login

Logo image
HomeAbout usProductsSupportForumsBlogCustomer Service

search inside this forum
search inside all forums
Updated Cyclone firmware prevents communication to EFR32
Nathan C. Mar 12, 2021 at 02:05 PM (14:05 hours)
Staff: Steve M.

  • Hi,

    We have a board that has an EFR32 micro, and our test program uses a Cyclone LC Programmer to program it.

    In January, we downloaded the latest cyclone_install.exe so we could create SAP images for a new board that has an EFM. Looks like the download included a version of Cyclone Control GUI that automatically updates Cyclone firmware to 10.27.

    With Cyclone firmware 10.13, we never had any problems communicating to the EFR32. Unfortunately, with 10.27, we invariably get a "Cannot enter debug mode" failure when we try to talk to the EFR32.

    My questions are:
    1. Do you know why this is happening?
    2. It seems like our quickest route is to downgrade our Cyclones' firmware to 10.13 and see if that works. How can we do so?

    I can answer any questions you have.

    Thank you,
    Nathan




    Comments

    • Hi Nathan,

      Generally, there are many changes that occur during firmware updates so there is a possibility something was changed that affected this specific processor algorithm.

      Two things to try before we have the last resort of downgrading.

      1) Can you test this firmware with another known good device? Are all the connections and power settings correct?

      2) Can you download the latest firmware from our website

      http://www.pemicro.com/support/downloads_find.cfm and then select the download entitled "Cyclone LC and Cyclone FX Programmer Installation Software". Check this new version and see if it resolves the issue.

      Steve

      • Hey Steve,

        As an experiment, we connected a debug header directly to our chip, bypassing the tester to remove any potentially extraneous variables. We found the following:
        * Using our last 10.13 Cyclone, we confirmed that we could program our image onto the EFR32.
        * Using a different Cyclone with the latest image (10.67), we got the "cannot enter debug mode" fail when trying to program.

        So to respond to your suggestions, 1) yes, everything was correct; and 2) the latest version did not work.

        Nathan

        • To be clear, we are supplying power externally using a DC supply, not via the Cyclone as part of the image.

          • Just now, we opened an older version of Cyclone Control GUI, checked the Force Firmware Update box, and downgraded a 10.27 Cyclone to 10.13. After doing so, we could talk to the EFR32 whereas we couldn't before.

            This isn't a long-term fix for our problem. To talk to the EFR32, we need a version of Cyclone Control GUI that allows 10.13. But to make the SAP files we need for our separate EFM product, we need a newer version of Image Creation Utility.

            Just maintaining these two different versions of Cyclone software is not a good solution.

            A good solution would be to prevent Cyclone Control GUI from auto-updating a connected Cyclone that has older firmware. If new firmware can cause breaking changes, there shouldn't be an auto-update feature that happens without the user's permission. Why not just auto-update if the user has deliberately selected Force Firmware Update?

            Nathan

  • To add a bit of detail, the previous version of Cyclone Control GUI was 7.35. That version left our Cyclones at 10.13. The new Cyclone Control GUI that we have is 8.20.

    • Hi Nathan,

      Sorry for the delay. Could you set up a Support Request on our website so I can try and replicate the issue? We may need your cfg files or some screenshots to accurately represent the issue. Ideally, updating the firmware should not break anything, especially being able to communicate with the processor. If you have not already, try decreasing the shift frequency or adding a small reset delay in your settings.

      Steve

      • Hey Steve,

        Sorry for the delay on our end. I'll set up a support request and can send whatever config files you need.

        Updates:
        * It appears that any image we generate in Cyclone Image Creator 8.36 triggers a freeze or loop on the Cyclone with 10.67 firmware where it just says Executing or Loading Image forever. 10.13 can program these images without a problem.
        * As you suggested, I tried lowering the shift frequency and adding a 100 ms reset delay in our image created with 7.10. Neither worked when trying to program with a 10.67 Cyclone.

Add comment


   Want to comment? Please login or create a new PEmicro account.







© 2021 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement