Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

search inside this forum
search inside all forums
MCUXpresso error 216 problem
Gary O. Mar 23, 2020 at 08:34 PM (20:34 hours)
Staff: Gilbert Y.

  • Hi --

    I have a Multilink Universal FX connected to a Kinetis K60 and MCUXpress on Windows 10. It's been running all day, but suddenly refused to download code, and came back with an Error 216 message. A note on NXP's website says that another user with a similar setup (different processor) fixed it by updating his Multilink software. I attempted to do that, downloading something called com.pemicro.debug.gdbjtag.pne.updatesite-4.5.5 SNAPSHOT.zip, which seemed like a good choice but it doesn't contain anything except .jar files, whatever they are.

    So...on to questions..

    Is "error 216" one of yours, or am I on a wild goose chase?

    Is the above file a reasonable solution, and if not, what is better?

    If that is the right file, what am I supposed to do with it?




    Comments

    • Hello Gary,

      Was there any text in the console that comes up when you attempt to download code or debug? Aside from running code, were there any changes to the project or MCUXpresso? Did the "Error 216" window pop up without any other text?

      The file that you downloaded is a plug-in update file for our plug-in in MCUXpresso. In MCUXpresso, go to "Help" -> "Install new software". A new window will pop up and at the top it will say "Work with:". Because you have the file installed, you can click "Add" and then "Archive" in the new window to select the download file. Once you hit OK and "Add". You should see a few entries pop up in the "Install" window's main white box. You will want to check the one that says "GNU ARM PEmicro Interface Debugging Support" and then hit "Next". You may need to agree to a license agreement, but once you continue all the way through, it will install the update and ask you to restart the IDE.

      -Gilbert Y.

      • Hi Gilbert --

        I downloaded the file per your instructions, and it needed to update several other files, and I had to shut everything off and reboot, but the fault 216 went away and everything seems to be OK now.

        Thanks for your help.

        Gary

        • Great! Glad that worked for you. Please let us know if you ever run into any other issues.

        • Hello Gary

          Just got the very same problem. My setup is a Kinetis K02 and MCUXpresso on Windows 10.

          I have installed com.pemicro.debug.gdbjtag.pne.updatesite-4.5.8-SNAPSHOT without success. What other files did you installed?

          Thank you
          Andre VB

          • Hi Andre,

            Have you tried installing the plugin through MCUXpresso? You can do this by going to "Help" on the top bar and clicking "Install New Software". In the window that pops up, there is a drop down menu to select were to see updates from. If you select the PEmicro one, you should see that there is an up for your plugin. If you see three items, please install the top item of the list that is for "ARM". Following through installation process should be able to update your plugin. If you receive any errors, please let me know what they are.

            -Gilbert Y.

Add comment


   Want to comment? Please login or create a new PEmicro account.







© 2020 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement