Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

search inside this forum
search inside all forums
Blue Led indicator blinking with Multilink FX
Lacouture P. Mar 18, 2020 at 04:25 AM (04:25 hours)
Staff: Gilbert Y.

  • Hello, 

    I have a PE Multilink FX that I had already used and it worked well.
    Today, I have difficulties to use the debugger, I have the blue ligth Indicator (power indicator) that is blinking when I connect the USB cable to my PC (no board connected).

    If I connect PE to my board, the led yellow is ligth and the blue is blinking, if I try to program my board (mcuxpresso, IMX 1064), I have a timout error.

    I have tried in a different machine, the result is the same. In the device manager, the Jungo show "USB multilink 2.0" when power on.

    The blink is regular, 1 sec period.

    1) Do you know have already this problem, why the blue ligth is blinking whereas it should be ligthed if it is powered?
    2) Is it broken and how can resolve it.

    It is the first time that I have this problem, I have no possibilities to buy a new one.

    Thank you


    • Hi Patrice,

      Were you able to resolve your MultiLink issue? Please let me know.

      -Gilbert Y.

  • Hello Patrice,

    The blinking blue LED means that the MultiLink may have failed a firmwareupdate and is now stuck in bootloader mode. This can easily be fixed by navigating to your C:\PEMicro\multilink_universal folder and using the "PEFirmwareConfig.exe" tool to reapply the firmware of your target device architecture (in this case ARM architecture).

    Have you recently updated Windows, MCUXpresso, or the PEmicro plugin in MCUXpresso?

    -Gilbert Y.

Add comment

   Want to comment? Please login or create a new PEmicro account.

© 2021 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement